1

I have a Ubuntu 18.04 dual booted on a Dell Inspiron. Whenever I suspend in Ubuntu (close the lid or something) and then use it again, the wireless does not connect to the WiFi of my institution (college undergrad), of which there are 3. It is detected and I can see it in WiFi settings, but it does not connect when I click on it.

The icon on the top left shows a question mark instead of the WiFi symbol(sic?) and there is no connection. If I use my mobile hot spot, it connects and works, if i reboot, then the connection works. Its not a problem of the WiFi, since I can connect to it on my phone and after rebooting my laptop. This is consistently the case.

I had deleted and then dual booted Ubuntu from scratch earlier, after this got on my nerves. It didn't happen for a few weeks, now its back. I've tried thesudo systemctl restart network-manager.service and all other variants of that I could find online. Nothing worked.

Results of lspci -knn | grep Net -A2 below

02:00.0 Network controller [0280]: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter [168c:0042] (rev 31)
Subsystem: Dell QCA9377 802.11ac Wireless Network Adapter [1028:1810]
Kernel driver in use: ath10k_pci
Kernel modules: ath10k_pci

ifconfig shows wlan0 to be UP when the wireless is misbehaving.

Please Help

New contributor
castle-max is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

castle-max is a new contributor. Be nice, and check out our Code of Conduct.

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.