1

My latop has Ubuntu 18.04.1

The Nautilus (Files browser) stop working after recent software updates ( I believe it contains some updates to Nautilus).

I tried remove and install the Nautilus, just won't fix the issue.

I tried to launch it from Terminal window by typing 'nautilus' , the error message is:

nautilus: symbol lookup error: /usr/lib/x86_64-linux-gnu/libexempi.so.3: undefined symbol: _ZN16WAVE_MetaHandler9kRIFFiXMLE

1

Similar bug had caused in multiple cases, where the ones that managed to fix it was by reinstalling the streamed broken package which in your case is libexempi3. Try reinstalling with,

sudo apt purge libexempi3
sudo apt install eog libexempi3 nautilus nautilus-share
sudo apt install -f

If that doesn't work, look for any libexemp library that is a dependency of nautilus in your system apt depends nautilus | grep libexempi and try reinstalling that package.

New contributor
MH Xion is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • Bingo! It perfectly solved the problem. I purged libexempi3 first, then remove the Nautilus and reinstall it, it pickup the correct libexempi3 dependency packages automatically. – Z Bob Jan 12 at 3:28

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.