0

I am trying to dual-boot Ubuntu 18.04 from an external SSD from my Lenovo Flex 5. I have already got it working on my desktop but it seems Lenovo restricts booting into anything but Windows, and I want to be able to work with the same OS on both devices.

So far I have backed up my EFI partition and replaced \efi\boot\bootx64.efi with grubx64.efi to override the restriction. From here I am not sure where to go because I already have Ubuntu installed on the SSD and I just want to be able to boot from it, and I have not been able to find any documentation on this.

Thank you for your help.

  • 3
    Welcome to Ask Ubuntu! What is the problem exactly? Like when you try to boot it, what happens? How did you find out "Lenovo restricts booting into anything but Windows"? Also please read How to Ask if you haven't already. – wjandrea Jan 11 at 19:13
  • I normally replace bootx64.efi with shimx64.efi, even though I do not have UEFI Secure boot on. But yours still should work. Some newer installs want mmx64.efi in /EFI/Boot also. That is key manager to allow driver install with secure boot on. My systems see external bootable devices as drives, not USB device. You may have settings in UEFI to allow USB boot which is separate from UEFI Secure boot on/off settings. Allowing USB boot is not considered Secure, so setting required. – oldfred Jan 12 at 17:39
0

Have you configured your BIOS settings to change the order of precedence for hard disk drives? Usually you should be able to use a function key such as F2 or F4 etc to access your BIOS menu at startup and change boot parameters

You can usually do a quick google search such as: lenovo laptop edit bios settings

Once you find the proper function key:

  • Restart your laptop

  • Hold the function key immediately at startup

  • Look for boot or hard drive options, move your HDD to the fist spot on the list

  • Save changes, restart and it should be working

  • I have changed the default boot option to my SSD, but it automatically changes and boots into Windows every time, which is why I am trying to do this. – brunerm99 Jan 18 at 18:18

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.