0

I use JabRef (Version 4.3.1) under Ubuntu, but the last time I tried to launch it, I got this error:

Error: Could not find or load main class org.jabref.JabRefMain

I have java-8-openjdk-amd64 and I think the problem has to do with OpenJFX (see FAQ) and the upgrade to Ubuntu 18.10
(The solution from this question does not work for me: JabRef error on launch)

According to this post "JabRef explicit requires JDK8 and openjfx8".

18.10 comes with openjfx 11+26-4 (18.04 had version 8u161-b12-1ubuntu2 according to ubuntu packages)

However, I could not figure out how to install openjfx8.

Update:

I figured out how to install openjfx8 manually (downloading and running the .deb file from ubuntu packages). Before I tried to use apt. But I still get the same error.

These are my currently installed versions:

$ java -version
openjdk version "1.8.0_191"
OpenJDK Runtime Environment (build 1.8.0_191-8u191-b12-0ubuntu0.18.10.1-b12)
OpenJDK 64-Bit Server VM (build 25.191-b12, mixed mode)

$ apt-show-versions openjfx
openjfx:amd64/cosmic 8u161-b12-1ubuntu2 upgradeable to 11+26-4
openjfx:i386 not installed
| improve this question | | | | |
0

Maybe you can try to install Oracle JRE. This way you will have JavaFX inside and no need to install it separately.

Apart from that if you want to continue trying with OpenJDK. I am not sure if you have 1.8.0_191 (8u191) can use openjfx version 8u161.

By the way your java can be headless because it is written OpenJDK 64-Bit Server VM (build 25.191-b12, mixed mode)

Then it does not have part of the GUI libraries. This can be a problem. You have to install not a headless java.

For more information: https://stackoverflow.com/questions/24280872/difference-between-openjdk-6-jre-openjdk-6-jre-headless-openjdk-6-jre-lib

https://stackoverflow.com/questions/32862344/what-is-the-difference-between-openjdk-7-jre-headless-and-openjdk-7-jrejdk/32862422

Good Luck!

| improve this answer | | | | |
  • I don't think it's headless, I assume I would have to specifically install openjdk-8-jre-headless (I ran sudo apt install openjdk-8-jre) – jost21 Jan 16 '19 at 11:57
  • I currently use the Oracle JRE and it works, but I would prefer to use OpenJDK – jost21 Jan 16 '19 at 11:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.