0

I often switch between between my headphones and speakers and this is the usual behavior that's supposed to happen:

  • If I unplug my headphones which is connected to the front panel, the sound output will automatically switch to the speakers which are connected to the back panel.
  • If I plug my headphones back in the front panel, the speakers connected to the back panel will automatically mute itself and I'd get sound output from my headphones. The volume profile will also switch.

I believe that's the default settings because I don't have any issues with 2 other computers with almost the same configurations.

This problem happened after I unsuspended my computer, so most likely not caused by a system update.

What happens now is :

  • Unplugging whatever connected to my front panel will not mute my speakers whatsoever.
  • The only way to get my headphones working is switching the output device to "headphones" in Pulseaudio Volume Control. Even though it displays as unplugged, I'm still getting audio output from it. This has been tested with different devices.

see_screenshot_here

Then I'd get audio output from both my speakers and my headphones. The auto-mute option in alsamixer does nothing. I've tried using the gnome version and it shoots a
** (gnome-alsamixer:12461): WARNING **: gam_toggle_set_state (). No idea what to do for mixer element "Auto-Mute Mode"!

error. I've tried restarting, reinstalling Alsa and Pulseaudio but the problem was still happening.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.