0

I am trying to install the Dynare-Matlab in my Ubuntu 18.10 system. Installing Dynare worked fine. But when trying the Dynare-Matlab I receive this error message about an invalid user in Matlab.

sudo apt-get install dynare-matlab
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
dynare-matlab
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/786 kB of archives.
 After this operation, 7.602 kB of additional disk space will be used.
Selecting previously unselected package dynare-matlab.
(Reading database ... 415538 files and directories currently 
installed.)
Preparing to unpack .../dynare-matlab_4.5.6-1build1_all.deb ...
Unpacking dynare-matlab (4.5.6-1build1) ...
Setting up dynare-matlab (4.5.6-1build1) ...
Building Matlab extensions (logfile at /tmp/dynare-matlab-mexbuild- 
1547212228.BOE1xZP)
chown: invalid user: ‘XXXXXXXX’
dpkg: error processing package dynare-matlab (--configure):
installed dynare-matlab package post-installation script subprocess 
returned error exit status 1
Errors were encountered while processing:
dynare-matlab
E: Sub-process /usr/bin/dpkg returned an error code (1)

Where I have XXXXXX is my university email address, from which I have my Matlab license. It did not ask me any information regarding licenses while installing. I don't know how I should proceed. Any help would be highly appreciated.

Best

PS: I hope this is the correct place to ask. I think it has something to do with Matlab on Ubuntu.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.