2

Problem: laptop's speakers sound quality is much worse than in windows. How to address this issue in Ubuntu 18.04?

2 Answers 2

9

According to https://forum.manjaro.org/t/solved-terrible-sound-in-linux-much-better-in-windows/8203/6 and http://www.alsa-project.org/main/index.php/Asoundrc

We have to do some manual settings editing on pulse audio config. The path is /etc/pulse/daemon.conf. Open a terminal by pressing ctrl+alt+t. First of all, backup the configuration file:

sudo cp /etc/pulse/daemon.conf /etc/pulse/daemon.conf.backup

Then type sudo nano /etc/pulse/daemon.conf

(If your file is empty, it means the file you are looking for is not in this directory. In this case, try to locate it: sudo updatedb, this will update your files database index. Then type locate daemon.conf to find the file location. Replace /etc/pulse/ with the path to your daemon.conf file)

Find the following lines (ctrl+w to find text in file) and replace your values with the following (lines might be in a different order in your system):

default-sample-format = float32ne
default-sample-rate = 48000
alternate-sample-rate = 44100
default-sample-channels = 2
default-channel-map = front-left,front-right

default-fragments = 2
default-fragment-size-msec = 125
resample-method = speex-float-5 
enable-lfe-remixing = no
high-priority = yes
nice-level = -11
realtime-scheduling = yes
realtime-priority = 9
rlimit-rtprio = 9
rlimit-rttime = -1
daemonize = no

Press ctrl+o to save changes, then press ctrl+x to quit

now type nano ~/.asoundrc in terminal and paste te following code:

pcm.!default {
    type plug
    slave.pcm hw
    }

This will bypass dmix for pulseaudio increasing sound quality by a lot. We can’t have more than one resampler because if we do it gets resampled twice and some sound quality is lost (as explained by Calthax in this thread).

Credits to Calthax and AlsaProject wiki page.

0

I had the same issue, even changing ~/.config/pulse/daemon.conf had no effect, but later I figured the issue was with Alsa not configured properly for my sound card which I fixed by adding the below line to /etc/modprobe.d/modprobe.conf:

options snd-hda-intel model=dell-inspiron-7559

(for my laptop 'dell inspiron 7560' as it has the same intel hd-audio chipset as dell-inspiron-7559, in fact all dell inspiron 7000 series laptops have the same audio card).

With Intel Corporation HD Audio Controller on laptop, you may need to add this line to /etc/modprobe.d/modprobe.conf or /etc/modprobe.d/sound.conf:

'options snd-hda-intel model=model'

Where model is any one of the following: dell-m6 dell-vostro generic laptop laptop-hpsense olpc-xo-1_5 dell-inspiron-7559 Note: It may be necessary to put this "options" line below (after) any "alias" lines about your card. You can see all the available models in the kernel documentation. For example https://www.kernel.org/doc/html/latest/sound/hd-audio/models.html, but check that it is the correct version of that document for your kernel version.

A list of available models is also available here. To know your chip name type the following command (with * being corrected to match your files). Note that some chips could have been renamed and do not directly match the available ones in the file.

$ grep Codec /proc/asound/card*/codec* Note that there is a high chance none of the input devices (all internal and external mics) will work if you choose to do this, so it is either your headphones or your mic. Please report to ALSA if you are affected by this bug.

3
  • 1
    What if this video gets deleted one day? And someone faces this issue and needs this answer? Just thinking, it best to put down the steps here in text before providing the link for more... May 13, 2020 at 0:58
  • So how do you use jack day-to-day ? Do you have it run at startup? I only use it for music production and I don't see the benefits of a standard "I want to watch a video/listen to music" use case.... Jul 17, 2020 at 9:27
  • For more information refer wiki.archlinux.org/index.php/Advanced_Linux_Sound_Architecture/… Oct 12, 2020 at 7:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.