I have MSN, XMPP, SIPE (with plugin) and Skype (with plugin) in my Pidgin configured. If I open Pidgin through Unity launcher, Unity menu or with autostart sometimes the Pidgin main contact window is hidden. If someone writes a message, the message window appears. Only by killing the task with "kill -9 **" helps and brings the window back to desktop by restart of Pidgin. Only closing Pidgin and starting Pidgin again doesn't work.

Thanks for helping.


Pidgin is not fully Unity compliant. I had the same issue: pidgin-not-showing-up-after-opening-it

Hope it helps.


I had found a trick before, that before shutdown I left the Pidgin contacts window open. The next time, I didn’t experience any problem in opening Pidgin contacts list.

But recently I think I’ve found kind of a solution and I just want to share.

Go to Preferences -> Interface, and put System Tray Icon on Always.

In fact, this is not a solution and you may still face the problem, but after this setting you don’t need to quit Pidgin to solve the problem.

My testing results in detail

Pidgin may be locked to the launcer or not:

  1. Locked to the launcher: the contacts list is shown by one click after restart and no problem. After a logout and login again, Pidgin will be active by one click and all its functions will work; for example, you can change the status from the messaging menu, but to see contacts list you should click the icon again.

  2. Not locked: you should make it active one time, for example through messaging menu; and click again to see the contacts list.

Anyway, no need to quit Pidgin and run it again – as I mentioned. So I recommend to users to follow this setting.


If nothing else, you can at least automate the client-bouncing procedure with a script. ^_^

kill $(ps ax | grep -m 1 pidgin | awk {'print $1'})
pidgin &

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.