2

I just restarted Linux, and a purple GNU GRUB 2.02 screen came up. When I press “c” to enter the command line and enter “ls,” it says “error: no such partition.”

I am completely new to Linux, and there is some very important data on this machine. Any help appreciated and I’ll respond quickly to comments. Thanks!

  • Welcome to Ask Ubuntu. My guess is you have just deleted a partition that was used in booting your system, so your MBR points to a now-deleted spot which needed to be fixed prior to reboot. I don't know what else is on your system, or anything else about it - so I don't see what else we help, but you need to fix using another OS on your system (usually done when you delete the partition) More details may help, but we support Ubuntu and official-flavors, not other Linux. – guiverc Jan 11 '19 at 3:42
  • Thank you for the response. I should clarify - it’s not my machine. The owner is away on vacation. I just pressed restart, and this happened. How can I change the partition the MBR points to? If it helps, I noticed that “OS” was in the “media” directory, which I thought was strange. – Jordan Jan 11 '19 at 3:50
1

So, dumbest solution possible: I fixed it by turning the computer off and on again.

Man is that a relief. Now that my heart rate is slowing down, I think I’m going to crawl back to being coddled by my Mac.

| improve this answer | |
  • It sounds like you had added a device (eg. usb thumb-drive) which caused the BIOS to re-order devices (ideally devices should be coded to UUID's or unique-IDs, but new people often use device names which are short alas can change if devices are added/removed or changes made in bios; though could also be on purpose so if devices change it will fail to boot). Either way thankfully it's solved. – guiverc Jan 11 '19 at 4:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.