0

I spent many long hours trying to install Ubuntu 18.10 on AsRock computer. It installs fine even on a Intel NVME ssd that the motherboard's UEFI utility can not use as a boot device. The problem is that after the installation finishes, the operating system will not boot. I tried several different ways, several media devices (hdd, ssd), different partition schemes, but it will not boot properly, no matter what I try. When I use a live USB image, I can mount and use the root partition/s just fine. There's definitely something wrong with the installer.... It could not even boot from an install done on totally empty hard drive with no partitioning done by me, when I let the installer do everything by it's own.... This should not happen.... Ubuntu reputation will suffer if this kind of behavior continues... The question is... Why is this happening ? Also, how can I make it boot after partitioning and installing ?

0

After a lot of time spent on this issue I was able to get it resolved by downloading the newest Ubuntu 18.10 image, burn it to an USB stick and going again through the installation process, like I did many times before. It worked from the first try, but at this time I had a totally empty hard disk to use. I went through the custom partitioning myself and even instructed it to put the root partition on the Intel M2 SSD (mounted on a adapter that is connected to a PCIe port on an older motherboard). I made the rest of the Linux partitions on the hard drive, except "/usr" that I did not separate from the root mount point. I tried using swap this time. Also, had about 75 MB for the "bios boot reserved partition" and another 75-100 MB for the "EFI reserved boot partition" that were the first two partitions created on the hard drive, in that order. It worked this time. I suspect there something wrong with the previous installer and/or the handling of the two boot partitions mentioned previously (bios_boot and EFI).

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.