0

Ubuntu version is 18.04.1 LTS

I need to upgrade node version. So following some forum recommendations I've uninstalled npm and node:

sudo npm uninstall npm -g
sudo apt-get purge --auto-remove nodejs

install latest version of node:

curl -sL https://rpm.nodesource.com/setup_11.x | bash -
sudo apt update
sudo apt install nodejs

checking results:

> node --version
v11.6.0
> npm -v
bash: /usr/local/bin/npm: No such file or directory

trying to fix:

sudo apt-get install npm
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 npm : Depends: nodejs but it is not going to be installed
       Depends: node-abbrev (>= 1.0.4) but it is not going to be installed
       Depends: node-ansi (>= 0.3.0-2) but it is not going to be installed
       Depends: node-ansi-color-table but it is not going to be installed
       Depends: node-archy but it is not going to be installed
       Depends: node-block-stream but it is not going to be installed
       Depends: node-fstream (>= 0.1.22) but it is not going to be installed
       Depends: node-fstream-ignore but it is not going to be installed
       Depends: node-github-url-from-git but it is not going to be installed
       Depends: node-glob (>= 3.1.21) but it is not going to be installed
       Depends: node-graceful-fs (>= 2.0.0) but it is not going to be installed
       Depends: node-inherits but it is not going to be installed
       Depends: node-ini (>= 1.1.0) but it is not going to be installed
       Depends: node-lockfile but it is not going to be installed
       Depends: node-lru-cache (>= 2.3.0) but it is not going to be installed
       Depends: node-minimatch (>= 0.2.11) but it is not going to be installed
       Depends: node-mkdirp (>= 0.3.3) but it is not going to be installed
       Depends: node-gyp (>= 0.10.9) but it is not going to be installed
       Depends: node-nopt (>= 3.0.1) but it is not going to be installed
       Depends: node-npmlog but it is not going to be installed
       Depends: node-once but it is not going to be installed
       Depends: node-osenv but it is not going to be installed
       Depends: node-read but it is not going to be installed
       Depends: node-read-package-json (>= 1.1.0) but it is not going to be installed
       Depends: node-request (>= 2.25.0) but it is not going to be installed
       Depends: node-retry but it is not going to be installed
       Depends: node-rimraf (>= 2.2.2) but it is not going to be installed
       Depends: node-semver (>= 2.1.0) but it is not going to be installed
       Depends: node-sha but it is not going to be installed
       Depends: node-slide but it is not going to be installed
       Depends: node-tar (>= 0.1.18) but it is not going to be installed
       Depends: node-underscore but it is not going to be installed
       Depends: node-which but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Question

Is any ideas, how to fix broken packages and install npm of latest version?

More details:

following answer.

dpkg --get-selections | grep hold

prints nothing.

> sudo aptitude -f install node
env: ‘aptitude’: No such file or directory

different answers have not helped me.

  • 1
    Possible duplicate of Unable to correct problems, you have held broken packages – karel Jan 10 at 22:01
  • @karel So... which package is broken? node, npm or different one? – Sergii Jan 10 at 22:05
  • To be honest if you install the node snap package you get all this: 1. npm is installed along with it 2. the latest version 3. your choice of all or any of the multiple versions of the node snap package 4. snap packages are standalone, so there are no possible problems due to broken packages - How can I install npm on 17.10? – karel Jan 10 at 22:10
  • @karel. I have no idea, how the links can help me fix my issue. following this links (with incomplete answers) issues and questions increases only. – Sergii Jan 10 at 22:20
0

I have not managed my issues with broken packages (it seems hard to detect ones, but hoping somebody knows answer). But I've managed issue with node and npm.

To install node i've used article how to manage nodes with nvm.

install nvm:

> curl https://raw.githubusercontent.com/creationix/nvm/master/install.sh | bash
> source ~/.bashrc # to reload env

check accessibe versions for install:

> nvm ls-remote # to find latest stable version
> nvm install v11.6.0 # install node

and now I've installed:

> node -v
v11.6.0
> npm -v
6.5.0-next.0

Npm can be updated following their instruction:

npm install npm@latest -g

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.