0

I'm running Ubuntu 18.10, and I've changed my login screen to lightdm (since I don't like the gdm3 screen), but whenever my laptop suspends, it'll still show the gnome lock screen to log back in. Lightdm works fine with a user lock, log out, and when the computer starts up, but there's something about the waking behavior after suspend that causes it to use the gnome screen. Does anyone know how to edit these settings?

0

In Gnome there is a setting deep in dconf, which locks the screen when suspended. This can be set with dconf-editor using the setting shown in the screenshot below:

enter image description here


To set is via CLI, open a terminal and enter the command

gsettings set org.gnome.desktop.screensaver ubuntu-lock-on-suspend false
  • Okay, but once I've disabled the gnome lock on suspend, can I enable lightdm to lock on suspend? – Dgamermaster Jan 11 at 17:17
  • You can certainly give it a try. I have recently had trouble with gnome-lock-on-suspend, where it refuses to let me log back in (it forces a new instance of my username). – Charles Green Jan 11 at 17:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.