8

I try to login Ubuntu 16.04 xrdp through window 10 with mstsc. It was successful in 2019/01/09 night, but failed in 2019/01/10 morning. An system auto-update log relating to xrdf is captured.

Connection log is listed below:

connecting to sesman ip 127.0.0.1 port 3350
sesman connect ok
seding login info to session manager, please wait...
xrdp_mm_process_login_response: login successful for display
started connecting
connecting to 127.0.0.1 5916
tcp connected
security level is 2 (1=none, 2=standard)
password failed
error - problem connecting

System update log is captured and shown below:

2019-01-10 02:31:21 status installed systemd:amd64 229-4ubuntu21.10
2019-01-10 02:31:21 status installed ureadahead:amd64 0.100.0-19
2019-01-10 02:31:22 status installed man-db:amd64 2.7.5-1
2019-01-10 02:31:22 status installed xrdp:amd64 0.6.1-2ubuntu0.1
2019-01-10 02:31:22 status installed libnss3-nssdb:all 2:3.28.4-0ubuntu0.16.04.4
2019-01-10 02:31:22 status installed libnss3:amd64 2:3.28.4-0ubuntu0.16.04.4
2019-01-10 02:31:22 status installed libnss3:i386 2:3.28.4-0ubuntu0.16.04.4
2019-01-10 02:31:22 status installed libc-bin:amd64 2.23-0ubuntu10

Hence, I deduce that xrdp or its related package was influenced by system update. Then methods[1-3] were tried but failed.

  1. Change password. http://xrdp-devel.766250.n3.nabble.com/Xrdp-devel-Need-a-little-help-td4024769.html
  2. Replace vnc4server with tightvncserver. https://raspberrypi.stackexchange.com/questions/56413/error-problem-connecting-to-raspberry-pi-3-with-xrdp
  3. Kill orphaned process. https://unix.stackexchange.com/questions/106974/windows-remote-desktop-login-failed-with-ubuntu-server-12-4

So, any idea to solve this problem ?

11

Check /var/log/apt/history.log, this was part of the upgrade from this morning (2019-01-10)

xrdp:amd64 (0.6.1-2, 0.6.1-2ubuntu0.1)

I then downgraded:

sudo apt-get install xrdp=0.6.1-2

It now works

  • Probably sudo apt-mark hold xrdp must be applied to prevent future update automatic updates of this package. – pa4080 Jan 22 '19 at 15:27
  • E: Version '0.6.1-2' for 'xrdp' was not found – stiv Aug 18 '19 at 9:38
8

This seems like there are some security improvements in xrdp which may not be completely mirrored in vnc (either the software or its config), which is why reverting to the older version works.

A workaround from the Ubuntu bug tracker issue for this:

Adding this in sesman.ini under [Xvnc] solved this issue for me :

param8=-SecurityTypes

param9=None

  • 1
    That worked! Obviously this error can happen for many reasons, as the question was asked a lot, with various solutions, but this recent update which I did not even notice, is what really was the case I had. You've saved my day! – noncom Jan 11 '19 at 6:31
  • Worked for me as well. I bet if we enabled encryption for VNC it would work too. The error is basically stating the encryption is not the required strength. Too bad it doesn't just state that in the error message. – Geofferey Feb 14 '19 at 9:40
  • Don't use this solution. These are parameters that xrdp passes to VNC, and it is literally telling VNC not to require a password. After I implemented this "solution", I discovered there were no logs, and then I realized that I could login to the existing shell without even using a valid password. In short: This creates a massive security hole. – David W Jul 8 '19 at 18:51
1

Dont install lastest version of xrdp. This problem happens with new version of xrdp

I face this problem too and I want to contribute so I made this comment, I fixed this by following commands:

sudo apt-get remove xrdp vnc4server tightvncserver
sudo apt-get install tightvncserver
sudo apt-get install xrdp=0.6.1-2
sudo service xrdp restart

Login with Remote desktop connection from windows or with Linux you can use Rdesktop or anything you want then it should work.

1

Do the following - confirm xrdp was updated:

# sudo cat /var/log/apt/history.log

Re-install xrdp with this version:

# sudo apt-get install xrdp=0.6.1-2

Re-start xrdp:

# sudo service xrdp restart

It should work!

  • This works but if you have auto updates the problem will come back. Seems the bug is still lingering in newer versions. – Peter Drinnan Jan 18 '19 at 16:59
  • 1
    @PeterDrinnan use the following to prevent an update in the meantime: sudo apt-mark hold xrdp – Jacman Jan 22 '19 at 21:36
  • Thank you @jacman. I found I also had to reboot my server (not just xrdp) to get it to work, but your suggestion is key. – Peter Drinnan Jan 24 '19 at 0:19
  • apt-get install xrdp=0.6.1-2 – stiv Aug 18 '19 at 9:38
0

After updating the file sesman.ini as indicated by Qwasson, execute:

sudo /usr/sbin/xrdp-sesman

0

The answer from QWassan above is on the right path. Following the ubuntu bug tracker link referenced one can find a update (entry #15) to address the xrdp issue. I have applied the update / fix / patch to two systems now and both were successful allowing access to ubuntu systems via MS Win 10 remote desktop.

0.6.1-2ubuntu0.3 package works well on fresh 16.04 install. Confirmed a local connection to the vnc server prompts for password now.

wget https://launchpad.net/~ubuntu-security-proposed/+archive/ubuntu/ppa/+build/16288483/+files/xrdp_0.6.1-2ubuntu0.3_amd64.deb
aptitude purge xrdp
dpkg -i xrdp_0.6.1-2ubuntu0.3_amd64.deb
aptitude install vnc4server

Not the answer you're looking for? Browse other questions tagged or ask your own question.