2

My processor does not runs at its full clock speed on Ubuntu, I also tried it on Arch Distros like Manjaro and faced the same issue. Below are the details of my system and what I have tried till now.

I installed Ubuntu 18.04

4.15.0-43-generic alongside of Windows 10 Home on

Acer Swift 3 SF315-41

The Max CPU speed and other beginner details are as follows:

Architecture:        x86_64
CPU op-mode(s):      32-bit, 64-bit
Byte Order:          Little Endian
CPU(s):              8
On-line CPU(s) list: 0-7
Thread(s) per core:  2
Core(s) per socket:  4
Socket(s):           1
NUMA node(s):        1
Vendor ID:           AuthenticAMD
CPU family:          23
Model:               17
Model name:          AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx
Stepping:            0
CPU MHz:             1574.846
CPU max MHz:         2000.0000
CPU min MHz:         1600.0000
BogoMIPS:            3992.66
Virtualization:      AMD-V
L1d cache:           32K
L1i cache:           64K
L2 cache:            512K
L3 cache:            4096K
NUMA node0 CPU(s):   0-7
Flags:               fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc rep_good nopl nonstop_tsc cpuid extd_apicid aperfmperf pni pclmulqdq monitor ssse3 fma cx16 sse4_1 sse4_2 movbe popcnt aes xsave avx f16c rdrand lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw skinit wdt tce topoext perfctr_core perfctr_nb bpext perfctr_llc mwaitx hw_pstate sme ssbd ibpb vmmcall fsgsbase bmi1 avx2 smep bmi2 rdseed adx smap clflushopt sha_ni xsaveopt xsavec xgetbv1 xsaves clzero irperf xsaveerptr arat npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbyasid decodeassists pausefilter pfthreshold avic v_vmsave_vmload vgif overflow_recov succor smca

However in windows the max processor speed is 3.6GHz

This max speed is also possible in Ubuntu as:

$ dmidecode -t processor | grep Speed
    Max Speed: 3600 MHz
    Current Speed: 2000 MHz
On some research I found that the Legacy Bootloader should be enabled and EFI should be disabled for the turbo frequencies to work normally. But my laptop manufacturer does not allows that and it has a primary Windows 10 OS.

Also is there any chance that the AMD microcode is not loaded in the init? If so, then how to solve this?

Any approach towards the problem or alternate solution would be helpful.

1

Turns out that loading the AMD-Microcode on init resolves this problem. We just need to edit the /etc/default/amd64-microcode file to load the microcode early.

sudo aptitude install amd64-microcode
echo "AMD64UCODE_INITRAMFS=early" | sudo tee -a /etc/default/amd64-microcode
sudo update-initramfs

Note that the lscpu | grep 'MHz' would still show the max frequency as 2.00 GHz but you can speed test by openssl speed and see the current clock speeds boost up.

0

I found this answer on the internet

sudo apt-get remove --auto-remove amd64-microcode

whether that will actually work I dont know

actually I just tried it and it works

  • I will test it, but can you give any source for the command above? I want to read some documentation on why are we removing amd64-microcode before running it. Will it reset some defined configuration for the microcode? Also did you had the same problem of the speed cap in processor and it got fixed by the command above? – Aizen Jan 10 at 11:38
  • I tried removing the file, the problem still persists @chernobyl – Aizen Jan 11 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.