0

I am trying to install Kubuntu 16.04 from hard drive and have followed the instructions from here and here.

Well I have to remove the extension from both vmlinuz and initrd, I had some question about the parameters but anyway it seems to work up to a point.

Unfortunately my process is stuck to a point where I get a message saying it could not find the ISO file. This seems strange enough since it clearly shows messages from the kernel. So, I guess it actually reads the files from the ISO file (where the previous file reside anyway). The actual message is this one (it's obviously a photo and not a clear one too): screenshot

Acccording to this answer my system is halted at the stage of mounting my root filesystem which in my case means the ISO file I guess.

The message:

...can't open /dev/sr0: No medium found

refers to my DVD drive and it's something like a bug (I have found some information about this one but lost the source to provide it here) I guess which I am not sure it has something to do with the actual problem here.

I have taken some action suggested elsewhere like booting into windows and using shutdown /s to have a clean windows system (although I am not sure I need a clean window system in this case anyway).

So, my questions are:

  1. is why does this behaviour occur in the first place (why do I encounter a mount problem) since the vmlinuz and initrd seems to be found.
  2. How do I proceed from here. Is there some option I can pass to read the actual ISO file for example?

My default system is an Kubuntu 14.04 32bit and I am trying to install a 64bit Kubuntu 16.04. My system is 64bit capable though since I also have 64bit win7 on it (dual boot).

If it helps the menunetry used in /etc/grub.d/40_custom is:

menuentry "Kubuntu 16.04 ISO no ext" {
set isofile="kubuntu-16.04.5-desktop-amd64.iso"
loopback loop (hd0,6)/home/jorge/Torrents/$isofile
linux (loop)/casper/vmlinuz boot=casper iso-scan/filename=${isofile} 
initrd (loop)/casper/initrd
}

and I don't have a separate /home partition.

3

You use the wrong path to your .iso-file in the linux-command:

linux (loop)/casper/vmlinuz boot=casper iso-scan/filename=${isofile}

should be

linux (loop)/casper/vmlinuz boot=casper iso-scan/filename=/home/jorge/Torrents/$isofile

You should also add the parameters noprompt and noeject to this line:

linux (loop)/casper/vmlinuz boot=casper iso-scan/filename=/home/jorge/Torrents/$isofile noprompt noeject

to prevent being prompted to remove the installation media when the installation is finished and the machine is going to be rebooted.

3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.