1

I was using Ubuntu 14.04 Server then upgraded to Ubuntu 16.04 and then to the latest LTS version of Ubuntu 18.04 Server.

Updates changed the running kernel version too. Now my computer has two Linux kernels, 4.15.0-43 generic and 4.4.0-141-generic. The first option is 4.15.x and it's stuck at a kernel panic if it is selected.

Here are screenshots of the error:

Kernel panic on Linux 4.15.0-13 generic kernel

And here is my installed kernels:

Installed kernels

Kernel 4.4.0-141 boots successfully. but I'd like to use new version of Linux kernel.

Also there is another issue with Ubuntu 18.10. There was the same error, but after community updated Linux kernel version to 4.18.x the problems were gone.

  • The beginnig of the stack trace is missing. Try to scroll up (unix.stackexchange.com/questions/60382/…) and post the beginning of the trace – Simon Sudler Jan 10 at 11:35
  • None of key combinations worked. Maybe cause of It's not a VM? – akikara Jan 10 at 13:16
  • You need some why of capturing the beginning of that kernel panic... check if the VM has some means of logging the console output – Simon Sudler Jan 11 at 7:11
  • It is a real machine not VM. Can I check log files if exist from the working kernel 4.4? – akikara Jan 11 at 7:28
  • No. I assume the problem is the root file system. So there is no way for the kernel to write that logfile. Does the 4.15 recovery mode boot? – Simon Sudler Jan 11 at 7:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.