2

On ubuntu 18.04, when I run sudo apt install simple-scan I get:

The following packages have unmet dependencies.
 simple-scan : Depends: libsane1 (>= 1.0.24) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I've seen others have had similar problems with broken packages but everything I've tried hasn't worked. Both sudo dpkg --configure -a and dpkg --get-selections | grep hold return nothing. However, sudo apt-get dist-upgrade outputs this, if it helps:

The following packages have been kept back:
  colord
0 to upgrade, 0 to newly install, 0 to remove and 1 not to upgrade.

I think I had used a PPA for simple-scan in the past but I'm pretty sure I have no PPAs now.

EDIT: In response to user535733's comment:

$ sudo apt-cache policy simple-scan
simple-scan:
  Installed: (none)
  Candidate: 3.28.0-0ubuntu1
  Version table:
     3.28.0-0ubuntu1 500
        500 http://gb.archive.ubuntu.com/ubuntu bionic/main amd64 Packages

$ sudo apt-cache policy libsane1
libsane1:
  Installed: (none)
  Candidate: 1.0.27-1~experimental3ubuntu2
  Version table:
     1.0.27-1~experimental3ubuntu2 500
        500 http://gb.archive.ubuntu.com/ubuntu bionic/main amd64 Packages

EDIT: And Organic Marble's comment:

$ sudo apt-cache policy colord
colord:
  Installed: 1.2.12-1ubuntu1
  Candidate: 1.3.3-2build1
  Version table:
     1.3.3-2build1 500
        500 http://gb.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
 *** 1.2.12-1ubuntu1 100
        100 /var/lib/dpkg/status

EDIT: Attempting to install libsane1 fails with:

$ sudo apt install libsane1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 libsane1 : Depends: libsane-common (= 1.0.27-1~experimental3ubuntu2) but 1.0.27+git20180317-xenial0 is to be installed
E: Unable to correct problems, you have held broken packages.
5
  • 1
    No, those commands won't help a version conflict ("held broken packages"). Please edit your questions to include the complete output of apt-cache policy simple-scan and apt-cache policy libsane1 – user535733 Jan 9 '19 at 21:26
  • 1
    Go down the rabbit hole, and try to install libsane1. If it fails, please edit your question to show complete output. – user535733 Jan 9 '19 at 21:57
  • 1
    How about apt policy colord? – Organic Marble Jan 9 '19 at 23:56
  • So, does the additional info I provided help either of you figure out how I can resolve this please? – snark Jan 17 '19 at 19:42
  • Any ideas please? I've tried using Synaptic too but no joy. – snark Jan 24 '19 at 20:18
3

In the end I raised this 'bug' and Sebastien Bacher gave me the answer. Because of an old PPA I had ended up with versions from 1.0.27-1~experimental3ubuntu2 rather than proper ubuntu packages. To restore the ubuntu ones I did:

sudo apt-get install libsane1/bionic libsane-common/bionic sane-utils/bionic

Then I was able to install both gnome-control-center (for Settings, which also depended on colord) and also simple-scan successfully with:

sudo apt install gnome-control-center
sudo apt install simple-scan

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.