0

I am trying to install yarn on Ubuntu 18.04.

https://yarnpkg.com/lang/en/docs/install/#debian-stable

I am trying to follow all steps from the link.

enter image description here

but I get no valid OpenPGP data found. error when I try to do something with

curl blah blah.. (link says I must need configure the repository)

  • 1
    Please don't put screenshots of text. Please edit your question and copy and paste the text from the terminal and format the pasted text using the { } icon above the edit window. – user68186 Jan 9 at 16:30
  • Do this: wget --quiet -O - /tmp/pubkey.gpg https://dl.yarnpkg.com/debian/pubkey.gpg | sudo apt-key add - and see if it works. If it still fails then your SSL is probably fubar. – Thomas Ward Jan 9 at 16:34
  • @ThomasWard thanks for comment. I think that worked. But could u help me with this problem too? when I try this command, curl -sL deb.nodesource.com/setup_11.x | sudo -E bash - root@LAPTOP-BKN76S4O:~# sudo apt-get install -y nodejs ubuntu shows me such error: E: Type 'gpg' is not known on line 1 in source list /etc/apt/sources.list.d/yarn.list. Do you know how to fix it? – javaprogrammer Jan 9 at 17:40
  • That sounds like a different question. – Thomas Ward Jan 9 at 17:56

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.