After scrolling with the mouse while pressing Ctrl in Nautilus, my icons for mounted hard drives have increased to the maximum size. (They are parallel to the thumbnails' view size, which looks like a bug to me. The size remains after a restart.) Anyway, I'd like to hide them. How can I do that?

6 Answers 6


For Ubuntu 19.10, the following commands does the trick:

gsettings set org.gnome.shell.extensions.dash-to-dock show-mounts false
  • 2
    On ubuntu 20.04 hide all icons on second screen (if use two screens).
    – momo2047
    Apr 26, 2020 at 23:57
  • 2
    The question is about hiding the icons from the desktop, nothing about the dock. Your answer is suitable for this question (which is already answered).
    – pomsky
    Apr 27, 2020 at 10:36

Open Terminal and run the following command:

gsettings set org.gnome.nautilus.desktop volumes-visible 'false'

Alternatively, if you have (GNOME) Tweaks installed, you can use it to disable 'Mounted Volumes' under Desktop:

enter image description here

This won't work for Ubuntu 19.04 and later as desktop icons are handled by a GNOME Shell extension instead of Nautilus for those releases.

  • 1
    the command just works like charm Jul 7, 2019 at 6:56
  • Doesn't work anymore in Ubuntu 19.10
    – Matthieu
    Nov 8, 2019 at 10:04
  • 1
    @Matthieu Yes, this won't work for Ubuntu 19.04 and later as desktop icons are handled by a GNOME Shell extension instead of Nautilus for those releases.
    – pomsky
    Nov 8, 2019 at 11:06
  • What is yout theme?
    – momo2047
    Apr 27, 2020 at 0:56
  • 1
    @Kohjah Does it actually have an option to disable drives? Last time I checked (long time ago), it only had enable/disable options for home folder and trash icon. If there is an option for mounted drives now, please post a new answer with details and preferably a screenshot. That would be valuable and much appreciated.
    – pomsky
    Apr 27, 2020 at 10:59

For Ubuntu 20.04 up to Ubuntu 20.10:

  1. Open the dconf editor, or if you don't have it installed, install it from the software center
  2. Click "org"
  3. Click "gnome"
  4. Click "shell"
  5. Click "extension"
  6. Click "desktop icons"

Then, on the window, disable the show-mount option, and you are done.

P.S.: If you want to disable the dock mount icon go back and click dash-to-dock option in the extension section of previous step and from there around the bottom disable the show-mount option.

Location link is: /org/gnome/shell/extensions/desktop-icons/

Notice: On Ubuntu 20.04, Ubuntu on wayland: there seems to be no option show-mount.

  • "then on the window" in step 6 - there is no entry for the mounted drive I'm looking for. I did find the option dash-to-dock but it's called "show-mounts" and applies to ALL mounted drives (which I'd like to keep as icons). Man... Ubuntu. Why are these things so hard? Jun 12, 2021 at 2:57
  • well, at least ubuntu( Linux generally) gives you these options to modify these settings and a great community like this will always help you...bruh the more you use Linux the more it became addictive btw. Jun 13, 2021 at 6:41
  • I'm all for Linux but it still has to be said that there is room for improvement! Jun 13, 2021 at 21:42

This answer might be useful for people using multiple monitors (tested on two monitors) with Ubuntu 19.10 and above.

Run the following command as mentioned in the other answers,

gsettings set org.gnome.shell.extensions.dash-to-dock show-mounts false

After you run this, your entire dock might get hidden in the secondary monitors (will be visible only one of the monitors).

To circumvent this, restart the gnome-shell*.

This can be done by pressing Alt+F2, typing r and hit enter. Once the gnome-shell restarts you should have the dock restored in the other monitors.

*If you're on Wayland, you may need to restart the shell by logging out and logging in.


Search for "Ubuntu Desktop" (is in settings)

There you can click on "Configure dock behavior" This opens a new window where you can select which drives to show (or hide all)


If you are on Ubuntu 19+:

1) Go to your menu and search for a program called [Desktop Settings] or [Desktop Icons]


2) Slide mounted drives so it is greyed out

  • 2
    Is the screenshot actually from a standard Ubuntu 19+ with GNOME? Looks like from Linux Mint (Cinnamon?) to me!
    – pomsky
    Apr 30, 2020 at 7:50
  • Can not find it!
    – Porcupine
    May 2, 2020 at 10:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .