0

This question already has an answer here:

Today I had to configure some CISCO switches & routers at school, and I used a USB to serial adapter. Unlike on Windows I didn't have to install any drivers; it was recognized immediately.

When I open puTTY through GUI and tried serial /dev/ttyUSB0 I got the following error:

Unable to open connection to /dev/ttyUSB0
Unable to open serial port

I thought I'd give it a try with root permissions sudo putty and it worked, but why!?

If I do have to give root permissions to puTTY what would be the way to do it? I read gksudo is removed from 18.04 and running an app as sudo <> is not recommended.

Thanks in advance!

marked as duplicate by N0rbert, Eric Carvalho, Charles Green, karel, Zanna Jan 9 at 8:41

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

Hit sudo adduser $USER dialout in terminal

Then log out & log back in again for this to take effect and try connect tty without root.

Not the answer you're looking for? Browse other questions tagged or ask your own question.