1

I have an Ubuntu Server 18.04.1 with LTSP installed and currently being used with 4 fat clients and 6 users. Each user has the same problem, they cannot log back in after they lock their session. After they enter the password, they get an "invalid password" error.

So far the only solution is to restart the clients, then sign back in.

I have been looking for the last month and a half and can't find anything. Nearly ever thing I've found suggested to deactivate the lock screen all together.

Does anyone know how to fix this issue?

The server doesn't have a desktop environment, but the ltsp clients are using two. Mate and KDE.

  • Consider to follow wiki.ltsp.org/wiki/Installation/Ubuntu and check syslog on the LTSP server for possible errors with TFTPD, NBD, SSH, Epoptes. It would be better if you write complete steps of LTSP server setup to help us to help you. – N0rbert Jan 8 '19 at 19:27
  • I followed those steps verbatim, with a little motification near the end to get the dual nics to communicate with each other. I can't find anything in the logs error wise. Do you think it could be that the users aren't saved on the ltsp image it's self? – rvcabc Jan 10 '19 at 19:30
  • Users are usually created on server. And their home folders are mounted via SSHfs. So credentials are only on the server. I have tested LTSP on 18.04 and can say that using Greek PPA is really needed. As far I can remember from my experience with LTSP running on 12.04 and 16.04 - it was recommended to remove screenlockers and screensaver from LTSP image. I tried to lock screen on 18.04 LTSP fat client with no problem on MATE. – N0rbert Jan 10 '19 at 19:42
  • @N0rbert Sorry for the 14 day late response. I'm now wondering if it might be a bug. I installed ltsp again on other machines as a test and found that they all have the same problem. Each machine were standard Gateway dual cores or HP dual cores and I've tried proxy mode and no-proxy-dhcp. If it is a bug, hopefully they figure it out. Again, I followed the instructions at wiki.ltsp.org/wiki/Installation/Ubuntu to the letter. (Copy paste really :P) – rvcabc Jan 25 '19 at 4:48
1

I had the same problem and after a lot of time, I was able to figure it out. The problem is that the /etc/passwdfile is missing on the clients. This is how I solved it:

  1. I installed LTSP in chroot mode (can be done after chrootless installation):

    sudo ltsp-build-client
    

    Execute this command on the server.

  2. Once that‘s done, enter:

    sudo ltsp-chroot
    

    to switch into the clients' file system. Then install a desktop environment of your choice.

  3. Use the following command to create a user:

    useradd NAME -m -s /bin/bash
    

    If you want to, you can allow sudo usage for that user.

  4. Type exit to quit the chroot.

  5. Execute

    sudo ltsp-update-image
    
  6. The problem should have been solved.

Note: This method will erase all of the client data, you have to reinstall everything!

| improve this answer | |
  • Thanks man. It totally worked. – rvcabc Mar 4 at 19:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.