0

Sorry for asking an already asked question, but I couldn't find anything that solved my problem. I did an extensive research on the internet (many users had similar problems) still I'm not able to fix it.

So, I messed up my laptops booting system: I installed Ubuntu in Legacy mode alongside a pre-installed Windows10 in UEFI. As you may know, one should't do it. I tried to restore things several times (by deleting the Ubuntu partition first and trying to install it again in EFI mode; by setting root and prefix to the right partition/path; etc...) - but nothing worked.

At the moment I cannot boot neither Windows nor Ubuntu. When I try to set the prefix to /boot/grub/i386-pc and then enter insmod normal or insmod linux I get:

filesystem '(hd0,X)/boot/grub/i386-pc/x86_64-efi/blabla.mod' not found

That's is because there is no "x86_64-efi" folder at all! The rescue grub automatically sets this folder in the path and I don't know why.

The only thing I can do is booting Ubuntu from my pen drive, though when I start the boot-repair it says:

The current session is in legacy mode. Please reboot the computer, and use this software in an EFI session. ...

Here is the link to my Pastebin.

I still can see that Windows10 partitions in Gparted, but I don't know how to get it to work/boot again. Do you have any suggestions?

  • 2
    Possible duplicate of Black screen after selecting an option from grub boot menu – karel Jan 8 at 13:40
  • You need to boot Ubuntu live installer in UEFI mode. Boot-Repair says it is in Legacy mode. You need to turn off fast start in Windows, report says data in cache. And you (almost) never install grub to a partition particularly FAT32 or NTFS. Fast start off:askubuntu.com/questions/843153/… We may have to run commands to clear the ESP's boot partition, but first try chkdsk on your ESP (sda1) from your Windows repair disk or dosfsck: askubuntu.com/questions/862724/grub2-failed-to-install/… – oldfred Jan 8 at 14:32
  • @oldfred I can't load windows anymore. Is there another way to disable fast start? – iLenia Jan 8 at 15:10
  • You may need a cold boot.askubuntu.com/questions/652966/… And then turn off fast boot in UEFI and boot Windows UEFI boot option. You may need f8 to get to Windows repair console also. Fast boot in UEFI is so quick you often have no time to press keys to get UEFI boot menu. And that is different than fast start up setting in Windows. – oldfred Jan 8 at 16:44

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.