New overwhelmed ubuntu user here, but so happy to be finally doing this. I have learned so much so far.

I just installed a package for a program called virtual moon atlas 6.0. It consists of three .tgz files; One for 386 processor, one for x86, and one for the data, and a .sh file. I ran the .sh file.

It installed, and the script ended with a output line saying that said in order to run the program run this following command. export LD_LIBRARY_PATH=~/virtual_moon/lib && ~/virtual_moon/bin/atlun

When I run this it says /home/josh/virtual_moon/bin/atlun: No such file or directory

Thinking I was some sort of genius and I decided to the run the following line of code with two vertical bars instead of two ampersands for basically no good reason. export LD_LIBRARY_PATH=~/virtual_moon/lib || ~/virtual_moon/bin/atlun

It ran without an error code, but I don't think it matters because I can't figure out how to launch the program or even find the program name to launch it from the command line by using the find command. What should I do?

Thanks for any help you offer. I am so happy to join this community finally.

  • Welcome to Ask Ubuntu!!!, did you try add LD_RUN_PATH=/your/path and run ldonfig ~/your/path?? – abu-ahmed al-khatiri Jan 8 at 8:39
  • Thank you! I ran the first line you gave me and it ran without an error. I ran the second one , and it said .... Can't create temporary cache file /etc/ld.so.cache~: Permission denied – josh Jan 8 at 8:48
  • try with sudo and don't forget to export your variable environments. finally make install again with some -LIBDIR flag see man make on your package – abu-ahmed al-khatiri Jan 8 at 8:54
  • How do I export my variable environments? – josh Jan 8 at 9:10
  • if you have LD_PATH=/your/path environments, you can add export LD_PATH also check it with echo $LD_PATH – abu-ahmed al-khatiri Jan 8 at 9:27

I think your problem's not about a variable environments, i tried with following :

  1. Extract the .tar of VAM6 package

    $ tar -xvf virtualmoon-6.0-linux.tar vmapro_install.sh licence virtualmoon-data-6.0-linux_all.tgz virtualmoon-6.0-linux_x86_64.tgz virtualmoon-6.0-linux_i386.tgz

  2. Extract the .tgz file to get the data of VAM6

    $ mkdir -p VMA6 && tar xzvf virtualmoon-6.0-linux_x86_64.tgz -C VMA6 bin/ bin/atlun bin/weblun bin/datlun bin/photlun bin/cclun lib/ lib/libvma404.so share/ share/applications/ share/applications/cclun.desktop share/applications/virtualmoon.desktop share/doc/ share/doc/virtualmoon/ share/doc/virtualmoon/copyright share/doc/virtualmoon/changelog share/virtualmoon/ share/virtualmoon/language/ share/virtualmoon/language/photlun.en.po share/virtualmoon/language/cclun.fr.po share/virtualmoon/language/datlun.fr.po share/virtualmoon/language/cclun.en.po share/virtualmoon/language/maplun.en.po share/virtualmoon/language/weblun.fr.po share/virtualmoon/language/maplun.fr.po share/virtualmoon/language/vmadatabase.en.po share/virtualmoon/language/photlun.fr.po share/virtualmoon/language/datlun.en.po share/virtualmoon/language/weblun.en.po share/virtualmoon/language/vmadatabase.fr.po share/virtualmoon/data/ share/virtualmoon/data/country.tab share/virtualmoon/data/retic.cur share/pixmaps/ share/pixmaps/cclun.xpm share/pixmaps/virtualmoon.xpm

  3. Install it using .sh script

    $ sudo ./vmapro_install.sh Virtual Moon Atlas You can use this script without parameter for the initial installation of virtualmoon-6.0 or give the name of the additional file to install: sudo ./vmapro_install.sh PictureApollo.tgz Installing /home/praz/Downloads/virtualmoon-6.0-linux_x86_64.tgz Select installation directory [/usr/local] :/usr/local Now installing Virtual Moon Atlas to /usr/local Are you sure? [y,n] :y Installing /home/praz/Downloads/virtualmoon-data-6.0-linux_all.tgz libvma404.so (libc6,x86-64) => /usr/local/lib/libvma404.so Installation successful Then run Virtual Moon Atlas with the following command: /usr/local/bin/atlun Or the Command Center with the following command: /usr/local/bin/cclun

  4. I choose to installation directory on /usr/local, finally open your VAM6 using :

    $ /usr/local/bin/atlun Init OpenGL Check Acceleration Check texture size Texture max: 16384 Check Bumpmap Driver: INTEL OPEN SOURCE TECHNOLOGY CENTER MESA DRI INTEL(R) BAY TRAIL GL_ARB_texture_env_dot3 OK GL_ARB_fragment_program OK SetBumpMethod Check MultiTexture InitLabel InitSprite Init OpenGL OK

The VAM6 package will appears daemon like

enter image description here

Hope this helps.

  • 1
    Haha. That should have been straightforward. I should have unpacked the .tgz file before running the .sh. I think I'll try to delete everything and try again. Thanks! – josh Jan 8 at 23:20
  • One more question however. I am going to use apt-get --purge, but how can I know what the package name is to use with this command? – josh Jan 8 at 23:28
  • @josh you can purge the package using sudo apt-get purge <your_package> or sudo apt-get remove <your_package> – abu-ahmed al-khatiri Jan 9 at 7:55
  • @josh yo're welcome! if my answer section can solved your issue, try to accept it with green checked of my answer!! – abu-ahmed al-khatiri Jan 9 at 7:59
  • I just checked it green. You wouldn't happen to know what the package name is for virtual moon do you? I can't find it using apt-cache. – josh Jan 9 at 23:43

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.