0

In a routine reboot event this morning, my Ubuntu machine can no longer show display and it was totally random (did not do anything).

Version

4.15.0-43-generic #46-Ubuntu SMP Thu Dec 6 14:45:28 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

With no display, I tried to teamviewer into the PC and all it shows is a black window. I then tty into it and managed to gain access.

Found a similar issue here but its not much help.

Some other observations:

  • Even BIOS screen won't show
  • NVIDIA drivers working correctly
  • sudo dpkg-reconfigure gdm3 will not return anything

GDM Service Output

● gdm.service - GNOME Display Manager
   Loaded: loaded (/lib/systemd/system/gdm.service; static; vendor preset: enabled)
   Active: active (running) since Tue 2019-01-08 11:15:05 +08; 15min ago
  Process: 6323 ExecReload=/bin/kill -SIGHUP $MAINPID (code=exited, status=0/SUCCESS)
  Process: 6320 ExecReload=/usr/share/gdm/generate-config (code=exited, status=0/SUCCESS)
 Main PID: 1114 (gdm3)
    Tasks: 3 (limit: 4915)
   CGroup: /system.slice/gdm.service
           └─1114 /usr/sbin/gdm3

Jan 08 11:15:05 rex systemd[1]: Starting GNOME Display Manager...
Jan 08 11:15:05 rex systemd[1]: Started GNOME Display Manager.
Jan 08 11:15:05 rex gdm-autologin][1164]: gkr-pam: no password is available for user
Jan 08 11:15:05 rex gdm-autologin][1164]: pam_unix(gdm-autologin:session): session opened for user rex by (uid=0)
Jan 08 11:24:06 rex systemd[1]: Reloading GNOME Display Manager.
Jan 08 11:24:06 rex systemd[1]: Reloaded GNOME Display Manager.

Can confirm that nvidia driver is working correctly,

+-----------------------------------------------------------------------------+
| NVIDIA-SMI 396.54                 Driver Version: 396.54                    |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 105...  Off  | 00000000:01:00.0 Off |                  N/A |
|  0%   39C    P8    N/A /  75W |    293MiB /  4038MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+
|   1  GeForce GTX 105...  Off  | 00000000:02:00.0 Off |                  N/A |
|  0%   35C    P8    N/A /  75W |     12MiB /  4040MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0      1295      G   /usr/lib/xorg/Xorg                             9MiB |
|    0      1735      G   /opt/teamviewer/tv_bin/TeamViewer              1MiB |
|    0      5329      C   ...rex/torch/install/bin/luajit   271MiB |
+-----------------------------------------------------------------------------+
  • 1
    This might sounds like a stupid question, but have you verified that your monitor is working correctly? With not being to access your BIOS as well it really sounds like a bad monitor. – Terrance Jan 8 at 4:18
  • Yes the monitor is working correctly, tested with other PC – Rex Low Jan 8 at 4:19
  • Try a BIOS reset on your motherboard. I am not thinking it is an OS issue because you should be able to see the BIOS and motherboard startup screens since those require no drivers. – Terrance Jan 8 at 4:21
  • Let me try that – Rex Low Jan 8 at 4:22
  • 1
    The last two things I think it could be would be either the power supply or the motherboard. When power supplies go bad, unpredictable things can happen. I would suggest getting your hardware checked. Again, this does not sound like a software issue simply because you do not get any of the POST or BIOS screen and nor do you get boot screens. All of which do not use any drivers. – Terrance Jan 13 at 2:54
0

I worked through a lot of issues. Problem is almost surely special kernel flags needed with Nvidia.

kernel 4.18.0.11.12 trouble: Video black screen

  • I have tried the changes you mentioned in your post, and downgraded + upgraded kernel to no avail. – Rex Low Jan 10 at 7:06
0

Nearly 7 days of research and trial and errors with no success, I nailed the possible causes down to hardware layer.

Eventually I had to replace the power cord and the computer is able to boot and showing display again. It would appeared that the fuse in the power cord is fried.

Let's observe for a few more days and see if the same problem comes back.

An odd problem indeed.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.