39

On a fresh install of 18.10 I attempted to install CPU usage widget

https://extensions.gnome.org/extension/120/system-monitor/

on that link it errors showing :

Although GNOME Shell integration extension is running, native host connector is not detected

1
  • fixed it by installing gnome-tweak-tool
    – TheDrev
    Sep 15, 2020 at 12:48

1 Answer 1

50

First install this (its what appears in your error popup):

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install chrome-gnome-shell 

However, on a new OS install you will still get errors until you also install these:

#  Ubuntu 20.04
sudo apt-get install libproxy1-plugin-networkmanager gnome-shell-extension-system-monitor

# Ubuntu 19.10
sudo apt-get install gir1.2-nm-1.0 

Or:

# pre Ubuntu 19.10
sudo apt-get install gir1.2-gtop-2.0 gir1.2-nm-1.0  gir1.2-clutter-1.0

Then bounce your GNOME Shell by typing:

  • Alt+F2, type r then Enter.

or bounce from a terminal by running

killall -3 gnome-shell

Now go back to

and turn on the monitor extension. The resource monitor widget will now appear on desktop top status bar.


UPDATE On Ubuntu 20.04, after doing the above, if it errors out, run the following in a terminal:

wget https://raw.githubusercontent.com/paradoxxxzero/gnome-shell-system-monitor-applet/fac6b7646346264bd75813a9d606dd5ba5152d6b/system-monitor%40paradoxxx.zero.gmail.com/extension.js -O ~/.local/share/gnome-shell/extensions/system-monitor@paradoxxx.zero.gmail.com/extension.js

Then bounce your GNOME Shell using:

  • Alt + F2, type r then Enter

I have run fresh installs of Ubuntu 20.04 on a handful of laptops and some work others fail to run this so the mystery continues...

UPDATE2 Apparently if you are running Chromium as a Snap in Ubuntu 20.04, this is a known bug. Using Firefox one can circumnavigate this issue and it should work.

PS and yes this also works for Ubuntu 21.10 ( as of May 21 2021 )

13
  • 11
    Installing chrome-gnome-shell package should be enough to fix the "native host connector is not detected" issue in general. You may need other packages to fulfil the dependencies of the extension in particular.
    – pomsky
    Jan 8, 2019 at 8:42
  • 4
    just a quick addendum - as @Ceisc commented here askubuntu.com/a/1034692/888540 - "the chrome-gnome-shell doesn't work if you install the version of Chromium that comes from the Ubuntu Software manager package, but does work if you install Chromium via apt"
    – hananamar
    Oct 30, 2019 at 8:58
  • 1
    When I am trying to install the additional packages with apt, in Ubuntu 19.10 I am getting the following error E: Package 'gir1.2-networkmanager-1.0' has no installation candidate
    – lefterav
    Dec 5, 2019 at 13:18
  • 2
    @ScottStensland what was different for me is that I couldn't run your last wget command, because I didn't have the 'extensions' folder in my '~/.local/share/gnome-shell/' so I created such dir and then that second one. And then i run that command. If this helps at all. Apr 24, 2020 at 18:42
  • 2
    Unable to locate package gnome-shell-extension-system-monitor on Ubuntu 20 Jun 6, 2020 at 16:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.