12

I'm using a Lenovo Thinkpad e580 with Ubuntu 18.04

I tried fingerprint-gui but it says "no devices found!".

lsusb command results this:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 06cb:00a2 Synaptics, Inc. 
Bus 001 Device 003: ID 04f2:b604 Chicony Electronics Co., Ltd 
Bus 001 Device 005: ID 8087:0a2a Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I suspect my device is Bus 001 Device 004: ID 06cb:00a2 Synaptics, Inc.

I tried a few online solutions, but I'm not able to find proper driver support for my system.

I found this link for Lenovo Thinkpad L390, it also has the same fingerprint device and it is certified by the ubuntu, given all hardware support.

As I understand the driver support is available for Synaptics, Inc. 06cb:00a2, but I'm not able to find it.

Please help me in figuring this out.

4

As far as I know you don't need fingerprint-gui in 18.04.

You need to install these packages to get it working:

sudo apt install -y fprintd libpam-fprintd

and then update your PAM configuration.

sudo pam-auth-update

Then you need to open Settings - Users, enable Fingerprint Login.


P.S. (if you use gnome-keyring)

Gnome-keyring is still cannot be unlocked with the fingerprint, you will need to enter your password at login or in the gnome-keyring propmt window to unlock it.

|improve this answer|||||
  • 1
    Didn't work on my Lenovo Yoga 720. – user3024311 Jan 16 '19 at 21:14
  • 2
    doesn't work. It cannot identify the fingerprint device. Which is why it doesn't show the fingerprint option in the user settings. – Sachin Jan 18 '19 at 7:48
  • Thank you, your solution worked for me on Thinkpad L470. – fear_matrix Dec 15 '19 at 5:40
  • 3
    didn't see any changes under users after making these changes – ohnoplus Jan 15 at 16:56
3

There are no Linux drivers for these fingerprint readers. There's a reverse engineering project that is in progress. Also Lenovo support staff made a claim that drivers are being developed for some of the synaptics fingerprint readers. Right now these devices are not usuable in any Linux distro. There is no point to try.

|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.