0

How can i install php extension imagick and gmagick on ubuntu 18.04 LTS, i tried imagick using :

sudo apt-get -y install gcc make autoconf libc-dev pkg-config
sudo apt-get -y install libmagickwand-dev
sudo peclX.Y-sp install imagick

But got error

ubuntu@ip:~$ sudo pecl7.3-sp install imagick
sudo: pecl7.3-sp: command not found

Also tell me about gmagick, I have installed both graphicsmagick and imagemagick just need to install php extention for both of them.

I am using Php7.3 ondrej,

Installed: php7.3 php-pear php7.3-curl php7.3-dev php7.3-gd php7.3-mbstring php7.3-zip php7.3-mysql php7.3-xml
  • Please run apt search php-imagick and see if imagick shows up! Also run the search for php-gmagick if both show then install with sudo apt install php-gmagick php-imagick My version of php is 7.2 so check and let me know! – George Udosen Jan 7 '19 at 17:17
1

I use php7.2 but from the same repo as your version of php. Check if these packages are present with the commands

apt search php-imagick | grep php-imagick
apt search php-gmagick | grep php-gmagick

If the search turns up positive, install both with the command

sudo apt install php-gmagick php-imagick

Restart apache afterward with

sudo systemctl restart apache2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.