0

I have installed Kubuntu 18.04 and I want to get a Chinese pinyin keyboard. I did the following

  1. sudo apt-get install ibus ibus-gtk ibus-gtk3 ibus-qt4 ibus-clutter
  2. sudo apt-get install ibus-pinyin
  3. sudo im-config and selected Ibus and clicked yes
  4. I opened the Ibus preferences application, it asks me if I want to run ibus-daemon and I clicked "yes". A couple seconds later a window pops up saying "Ibus daemon could not be started in 5 seconds"
  5. I then go to the terminal and type "ibus-setup" but the same thing happens

After step 5 i got the following message in the terminal

    (ibus-daemon:3641): IBUS-CRITICAL **: 15:56:33.697: 15:56:33.697641: ibus_write_address: assertion 'pf != NULL' failed
portal is not running: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.portal.IBus exited with status 1
Gtk-Message: 15:56:39.247: GtkDialog mapped without a transient parent. This is discouraged.

I can select Chinese keyboard layout in the keyboard settings but no Chinese characters show up when I type.

Thanks in advance!

  • You need to reboot (or at least relogin) to make the im-config change effective. – Gunnar Hjalmarsson Jan 7 at 15:25
  • I have done it but nothing happens – AttoCell name Jan 7 at 15:28
  • Another thing is that you should start using ibus-setup for handling the input sources (both IBus and XKB layouts) instead of the KDE settings. The Chinese layout you see in the KDE settings is not an IBus input method. – Gunnar Hjalmarsson Jan 7 at 15:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.