0

All was working perfectly until the update. Today I thought that some security updates of packages will be better for our server security. So, I have updated only security updates using Webmin(webmin.com) after all updates completed without any errors and automatically rebooted our server.

after that when I tried to run sudo command(was 'sudo cp') but it was showing error like cannot find ip-172-1-1-1(IP of ec2) host then i solved that by adding a line: 127.0.1.1 ip-172-1-1-1.

then when tried to run sudo certbot --apache then it was showing error: command not found! (I was shocked because previously it was installed and working perfectly without any error). and then i have noticed that my login welcome of Ubuntu has changed previously there were an update notice for Ubuntu 18 and now there is showing an error: Failed to connect to https://changelogs.ubuntu.com/meta-release-lts. Check your Internet connection or proxy settings and then i tried ping google.com and it is saying now: ping: unknown host google.com

*** Please help me, I'm not very familiar with Networking and System Administration, I just learned to do necessary things in order to deploy my client Applications(Laravel, Slim, PHP etc) such as: apache2, certbot(LetsEncrypt), php config, webmin, roundcube, service: start, restart, reload etc commands.

  • Rather than pinging google.com, can you ping 8.8.8.8 instead? – Lewis Smith Jan 7 at 12:12
  • Yes, I can ping 8.8.8.8, and results: 64 bytes from 8.8.8.8: icmp_seq=1 ttl=119 time=1.33 ms – Riajul Jan 7 at 12:13
  • Ping results of 8.8.8.8 kinda infinite! – Riajul Jan 7 at 12:14
  • Okay then we have a DNS problem. Can you cat /etc/resolve.conf and post the Nameservers? – Lewis Smith Jan 7 at 12:15
  • FYI - Ping will continuously run until you CTRL+C is to cancel. – Lewis Smith Jan 7 at 12:16
0

The Internet and Email Problem has been solved by Updating Ubuntu OS 16 to 18 and all it's packages using the command sudo apt-get upgrade. To update OS first I needed internet access so I followed @Lewis Smith comments:

comment: Edit resolve.conf as root and add nameserver 8.8.8.8 nameserver 8.8.4.4 on separate lines.

My Comment:

adding nameserver does fix internet access problem but still, email service does not work. using Roundcube, Postfix, Amazon SES previously mail was working perfectly but now no mail is being sent to the destination(no error is showing in Roundcube).

Although I couldn't find resolve.conf file in etc folder so edited resolv.conf. and then some hours later I thought to try updating the OS and its packages. and this try has worked!

The command I used: sudo apt-get upgrade

I have figured out the problem or mistake I have made:

While I was using Ubuntu xenial version 16 I updated security updates of bionic that is Ubuntu 18, that was my mistake and so foolish I didn't know the Ubuntu version nickname. So the bionic security updates wasn't compatible with Ubuntu xenial 16 that was the main reason of all problems happened to me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.