11

Unable to install Canon LiDE 300 on Ubuntu 18.04. How to solve it?

4
  • Hello and welocome to AU. Please review this link and edit your question accordingly to improve your chances of getting a correct and accurate answer. Jan 7, 2019 at 13:17
  • 1
    Have you tried downloading the linux drivers from canon? Jan 7, 2019 at 15:45
  • Another link: canon.co.uk/support/consumer_products/products/scanners/…
    – Parto
    Mar 23, 2019 at 6:37
  • Comment: I have a LiDE 110, and came to this thread when trying to configure it on my ubuntu 18. In my case, xsane was already installed, just ran it and bam, everything worked smoothly... in case someone also has a 110, this Q&A helped me out as well :)
    – DarkCygnus
    May 14 at 1:22

4 Answers 4

16

For Ubuntu 20.04, this scanner does not work straight forward. The ippusbxd driver tries to get the USB device, and it locks it. In dmesg -w there is a line:

usb 1-11: usbfs: process 5756 (ippusbxd) did not claim interface 0 before use

To resolve the problem:

sudo apt remove ippusbxd

and replug the scanner ! (tested on live USB unmodified Focal).

6
  • 2
    This absolutely worked for me. Thanks!
    – Kagetsuki
    Jun 1, 2020 at 7:56
  • What you describe is what I experienced, but I couldn't fix it by just removing ippusbxd, I had to also add saned to lp group by doing sudo adduser saned lp. I figured this since the device was under the lp group in /dev/bus/usb... Thanks! Aug 3, 2020 at 23:24
  • Just noting I did NOT need to add saned to the lp group. YMMV?
    – rik-shaw
    Aug 16, 2020 at 22:32
  • I can say that this also works with LiDE 400 on Ubuntu 20.04. Moreover, I no longer need to use the precarious scangearmp2 software that Canon provides as the scanning software. Aug 29, 2020 at 15:42
  • I had the same issue with a Lexmark printer on Ubuntu 20.04 and solved it by removing ippusbxd. Super!
    – UlfR
    Jan 19, 2021 at 8:59
14

Download the scanner's linux driver from the Canon website. It's the same driver for related models: scangearmp2-3.70-1-deb

Unpack and install the driver from the download directory:

./install.sh

Canon's own driver is not enough though, to get the Canon scanner working. It only half works. Assuming you have installed Sane. Sane will recognise the scanner.

$ sane-find-scanner

found USB scanner (vendor=0x04a9 [Canon], product=0x1912 [LiDE 400]) at libusb:003:008

But it won't work.

$ scanimage -L

No scanners were identified

$ scanimage --format=png > test.png

scanimage: no SANE devices found

Likewise, SimpleScan won't yet detect the scanner.

It will scan at this stage by running Canon's own scanning software, supplied with the scanner download: scangearmp2. But this software is as rudimentary as toddler's tea set. It won't even let you change the resolution, filetype or scan area.

But thanks to the good work being done by @pekhterev and Rolf Bensch, the scanner will run if you install some more home-grown software.

sudo add-apt-repository ppa:rolfbensch/sane-git
sudo apt-get update

(source here)

sudo apt install libsane-common
sudo apt install sane-utils
sudo apt install xsane

(source)

The scanner worked from Xsane, after doing this. And from Gimp, by calling Xsane (it sees it as a pixma:04A91912 scanner). But the image was dull.

Thankfully, it now also works from SimpleScan.

.

Canon, btw, when I contacted them for help because their scanner didn't work, said. 'we don't support linux'. I said - but you've taken the time to supply a driver - surely you would want to make sure it actually worked when people installed it. They said, 'we don't support linux'.

2
  • 1
    The ppa address changed to: sudo add-apt-repository ppa:sane-project/sane-git . With this info I got the CanoScan Lide 400 working on Ubuntu 18.04 with sane.
    – CyberFly
    Feb 17, 2021 at 14:12
  • 1
    If you want release instead of nightly snapshots, you can use sudo add-apt-repository ppa:sane-project/sane-release Feb 21, 2021 at 16:08
1

Finally found a USA Linux driver from Canon: USA driver link Linux 64 bit

0

Just to add my amateur advice. After all the above, xsane still could not find the USB scanner on my system.

Make sure the scanner is not asleep, plug it out and then in, then run:

sudo sane-find-scanner

you should see this or something like it:

found USB scanner (vendor=0x04a9 [Canon], product=0x1913 [LiDE 300]) at libusb:001:009

Go to the directory /etc/sane.d/canon_dr.conf and put the vendor and product numbers in that file.

At the bottom of the files I added the following lines:

# LiDE-300
usb 0x04a9 0x1913

I also stuck that in canon630u.conf (just to be sure)

After that, xsane finds the scanner and I can use it.

Not the answer you're looking for? Browse other questions tagged or ask your own question.