0

I turned on my laptop and several drivers are unclaimed, including wifi and both USB-B ports. The USB-C port is working and I'm able to use the trackpad. It's also recognizing my flashdrive. My bag fell over the other day with the laptop in it, though it was in a case. I'd like to know what I can do diagnostically to see what needs to be done. There's no visible external damage and the OS (18.04.1) is running fine. I typed in:

sudo lshw -C network

This was returned:

*-network UNCLAIMED

 description: Network controller

 product: Wireless 3165

 vendor: Intel Corporation

 physical id: 0

 bus info: pci@0000:01:00.0

 version: 79

 width: 64 bits

 clock: 33MHz

 capabilities: pm msi pciexpress cap_list

 configuration: latency:0

 resources: memory: d1000000-d1001fff

There is no Ethernet port on my laptop. I'm wondering if I can connect via a wired connection to my phone's hotspot, although I'd probably need to download a driver.

Edit: interestingly, when I'm in BIOS, I can use my wireless mouse which infers that it is not physical damage.

  • What is the exact response to the terminal command: sudo modprobe iwlwifi && dmesg | grep ath Welcome to Ask Ubuntu. – chili555 Jan 7 '19 at 0:27
  • modprobe: ERROR: ../libkmod/libkmod-module.c:382 kmod_module_insert_module() could not find module by name='iwlwifi' // modprobe: ERROR: could not insert 'iwlwifi': Unknown symbol in module, or unknown parameter (see dmesg) – defarm Jan 7 '19 at 5:11
  • Thanks. The // denotes a new line in the output. – defarm Jan 7 '19 at 5:11
  • Also, updated the capability section of lshw in the original question – defarm Jan 7 '19 at 5:25
  • My apologies for my error. I meant to ask for: dmesg | grep iwl Sorry. – chili555 Jan 7 '19 at 14:07
1

In our chat, we searched your system for the correct driver iwlwifi. We found that it was present in kernel versions 4.15.0-36 and -38 but not the kernel version you were then running, -39.

I suggested that you interrupt the boot process at the GRUB menu and, under Advanced options for Ubuntu, select -38 to see if the wireless was then working as expected. It was.

I suggested that you allow Update Manager to run and update your system, hoping that an even newer kernel version would be installed. It was, that is, 4.15.0-43. When you rebooted into -43, the wireless also worked as expected.

Since the iwlwifi module didn't exist in -39, but did in -38 and -36 and, obviously, in -43; I suspect that the update to -39 went wrong somehow; the correct driver(s) were not properly installed. A clue was given in your original comments: "Also, when I run lshw in terminal, there are several other unclaimed devices. Here's which: display, generic 0-4, communication, network, memory, multimedia, serial, and volume 0." Evidently, many other drivers were not correctly installed.

I am glad your wireless is now working as expected.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.