1

So today it's Recoll, it says it's installed but it won't launch. When I try through the terminal it says

error while loading shared libraries: libQt5Widgets.so.5: cannot open shared object file: No such file or directory

So I tried

sudo apt-get install libqt5-widgets

and get

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libqt5-widgets

I haven't been able to install any new programs since I got 18.04 a month ago, some of them install and even launch but they never work, there is always something missing. I always get a message about some missing dependency.

I have all the repository boxes ticked in the settings.

I've tried apt-get update and apt-get upgrade

I've looked at threads with similar topics and no answer.

apt-cache policy recoll
recoll:
  Installed: 1.23.7-1
  Candidate: 1.23.7-1
  Version table:
 *** 1.23.7-1 500
        500 http://ftp.heanet.ie/pub/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status


$ which recoll
/usr/bin/recoll

This happens no matter what program I try to install.

Thanks.

  • The library appears to be provided by package libqt5widgets5 – steeldriver Jan 6 '19 at 18:45
  • 1
    Please add output of apt-cache policy recoll, which recoll, ldd $(which recoll) and ldd /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5 | grep not to the question. – N0rbert Jan 6 '19 at 20:50
  • Done! I meant to say this happens regardless of program... – Rabbit Jan 7 '19 at 16:41
1

According to the search on packages.ubuntu.com you need to get libqt5widgets5 package with

sudo apt-get install libqt5widgets5

Also for your information Recoll is available in official repositories (in universe pocket) too and installable with

sudo add-apt-repository universe
sudo apt-get install recoll

To be completely sure that your system integrity is complete consider to use debsums.

| improve this answer | |
  • Yes I got it from the official repositories, I get everything from there, but no matter what I get from the official repositories there are missing dependencies. So yeah, "'universe' distribution component is already enabled for all sources. " – Rabbit Jan 6 '19 at 20:47
  • When i did that it said "libqt5widgets5 is already the newest version", and I still get the same error message when i try to open recoll. I don't understand what the link you sent me wants me to do? – Rabbit Jan 6 '19 at 20:49
  • Ah ha ok i figured out what the debsums stuff was about, sorry it took me a while. Yes, that worked, sorted out all the missing dependencies and all the programs I've been trying to install are working now. Thank you! – Rabbit Jan 15 '19 at 17:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.