0

This is MacBook with latest nvidia-340 driver. I had to use power button. (How do you use Magic SysRq key on Macbook keyboard anyway? Even USB keyboard did not work on booting.)

Could this be due to /etc/initramfs-tools/conf.d/resume not existing? I think it is necessary only on resume from suspend to disk (hibernate).

Even recovery boot did not pass. How to boot this thing again?

UPDATE:

I tried booting by live USB stick again, which worked, and later I could finally boot the device from the internal storage. I do not know what affected, since I did not change files AFAIK.

UPDATE:

Related bug report

enter image description here

0

Your "resume" file needs to contain the UUID of the partition you are using for resuming - it will not exist, if no swap partition has been set or activated. Lately some distros started using swap files instead of swap partitions. In this case the GRUB bootloader has to know where to look when resuming. So you need to find out

  • if your swap partition is enabled (swapon -s)
  • or if you are using a swapfile

See here

But nonetheless I've never succeeded in resuming from hibernate with a nvidia driver. Neither on a laptop or a workstation. Whereas suspend and resuming from it should work.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.