0

Just installed Ubuntu 18.10 two weeks a go and it's my first Linux distro. Everything's working fine and I want to start playing with the terminal.

So I want to install this still in beta ProtonMail bridge for Thunderbird and the instructions are asking me to copy this :

sudo mkdir -p /usr/share/debsig/keyrings/E2C75D68E6234B07
sudo gpg --dearmor --output /usr/share/debsig/keyrings/E2C75D68E6234B07/debsig.gpg bridge_pubkey.gpg

Problem is that I always get this response :

gpg: WARNING: unsafe ownership on homedir '/home/ulfberht/.gnupg'
gpg: can't open 'bridge_pubkey.gpg': No such file or directory
gpg: dearmoring failed: No such file or directory

Other information that might help you understand my problem, I tried :

ls /usr/share/debsig/keyrings/ and it gives me "E2C75D68E6234B07" correctly

I have installed debsig

bridge_pubkey.gpg is a document I have in my documents folder

As a sign of gratitude, here's the latest links to the linux bridge :

Deb: https://protonmail.com/download/protonmail-bridge_1.1.0-1_amd64.deb
RPM: https://protonmail.com/download/protonmail-bridge-1.1.0-1.x86_64.rpm

Thanks in advance!

  • I don't think the format of your key-fetching string is right. Is there anything in /usr/share/debsig/keyrings/E2C75D68E6234B07? (ls /usr/share/debsig/keyrings/E2C75D68E6234B07 will tell us) – Thomas Ward Jan 5 at 18:34
  • Terminal doesn't do anything when I copy ls /usr/share/debsig/keyrings/E2C75D68E6234B07 – Ulfberht Jan 5 at 18:38
  • Ok, from where do you execute those commands? If it is not from the directory where bridge_pubkey.gpg is located, it will not find it like that. – Sebastian Jan 5 at 18:38
  • Ok I think you helped me find the problem. I have the document in my /home/ulfberht/Documents/ProtonMail/bridge_pubkey.gpg. I will try to use this instead – Ulfberht Jan 5 at 18:42
  • Tried : sudo gpg --dearmor --output /usr/share/debsig/keyrings/E2C75D68E6234B07/debsig.gpg /home/ulfberht/Documents/ProtonMail/bridge_pubkey.gpg gpg: WARNING: unsafe ownership on homedir '/home/ulfberht/.gnupg' File '/usr/share/debsig/keyrings/E2C75D68E6234B07/debsig.gpg' exists. Overwrite? (y/N) – Ulfberht Jan 5 at 18:47

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.