0

I have a pretty standard hardware set up, Asrock TaiChi mb, 16G ram, NVidia 1050, couple hard disks. Running Ubuntu 18.10 with standard everything.

While still on 18.04 the system started crashing, just randomly freezing up while on the screen blank. Mouse/keys wouldn't wake it up. I ended up wiping the boot disk and installing 18.10 fresh, still random freezing. I think its happening more frequently as time goes on.

To get the system back, I have to turn the system off and leave it off for a couple minutes. Just restarting doesn't work. What I see when I power cycle is the normal bios startup screen, then a blank magenta screen that stays blank for several seconds, then (maybe) the magenta Ubuntu screen with the orange/white dots, and finally the login screen. This whole process seems to take much longer than it used to, especially the blank magenta screen.

I assume there is some piece of hardware that is overheating that is causing this since the box seems to need to cool down... but I have no idea how to figure out what is going on. Can someone please walk me thru how to figure out what is spazing out?

thanks

  • 1
    askubuntu.com/questions/15832/how-do-i-get-the-cpu-temperature/… psensor ( sudo apt install psensor ) displays the temperatures of the CPU, GPU and hard disks and also displays the fan speeds. – karel Jan 5 at 15:43
  • installed psensor. – Vijay Jan 5 at 16:18
  • Tctl seems a little high, running around 130 F with cpu usage just 1%. I don't know if this is a particularly "bad" value. Its just higher than the other values. Context? – LarryM Jan 5 at 16:25
  • 130 F is an OK temperature reading. It might be caused by a bad RAM stick or a bad graphics card if there is one. – karel Jan 5 at 16:57
  • Is there any sort of RAM testing program? Long ago I had bootable memory testing program. Long forgotten its name... – LarryM Jan 5 at 17:11
0

Might be good to check the SMART data on your drive. Gnome Disks can do this.

  • How do I do this ? – LarryM Jan 5 at 16:26
0

I think I've solved my problem. What I did was boot a 18.10 on a USB, then ran "e2fsck -c -c" on the drive. This found a few bad sectors and apparently one or more of these had something to do with booting as the drive stumbled and wouldn't boot. I tried boot-repair, no avail. Reloaded 18.10 and the box ran over night and boots on a normal restart, not just on a power off (and cross my fingers)

I do have one more question tho: Now the boot process stops on a screen with four choices, "Ubuntu" is the default and starts the system. What do I need to do to skip this screen and go right to loading the system?

  • You would have to edit the /etc/default/grub file to modify the behaviour of the loading screen, but maybe you want to post that as a separate question. – Sebastian Jan 12 at 14:24

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.