2

Recently yesterday at Friday, I got to try my laptop to run Linux and it worked. The brightness was controllable until I tried to reboot it. After rebooting, somehow during the start up I tried decreasing the brightness usign the keyboard, but then it did decrease but it instantly went to the lowest brghtness and then stayed there permentantly.

Here is the list of what I tried to troubleshoot the problem:

  • Accessing the /etc/default/grub file via the terminal to change the editing permissions and changing GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" by adding acpi_background=video and acpi_bakcground=vendor to quiet splash and updating the file and rebooting did not work.
  • Installng xbacklight and brightness controller did not work.

Are there any other ways of fixing this problem. I have an important assignment due in several days and can not work with low brightness. If any of you found a solution, reply this ASAP.

1

Can you please tell us which laptop you are using?

Please try to test the kernel parameter acpi_osi='!Windows 2012' first without acpi_background and then with. If that doesn't work either, you can test Windows 2009. Whether a version will work depends on whether your BIOS can do something with this information.

Edit:

To edit /etc/default/grub, you must start at first the shell. It is important that you edit the file with any editor such as nano with sudo. Without root privileges you cannot edit this file.

Before making any changes, we create a backup:

sudo cp /etc/default/grub /etc/default/grub.bak

Now open the original file:

sudo nano /etc/default/grub 

and change the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi='!Windows 2012'".

Make sure that you do not forget the characters ' ', the space between each parameter and the enclosing characters " ". Save (in the case of nano) the file with CTRL+O and exit with CTRL+X.

Now the changes have to be applied:

sudo update-grub 

and finally you can reboot your system with:

sudo reboot

EDIT 2: Here is a similar problem. Maybe you will find some recommendations there: Ubuntu 14.04 brightness problem (Lenovo Z500)

  • Thanks for the reply! I am a beginner of using Linux so I am not sure if I am supposed to enter that in the terminal or access th BIOS. Please be more clear with the instructions. My laptop is a Lenovo Ideapad Z500 Touch. – Moodles1406 Jan 5 at 15:14
  • I added the double speech mark at the end, wrote sudo reboot and I tried using the dedicated brightness changing buttons and it worked! My man! – Moodles1406 Jan 5 at 18:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.