0

My laptop using Ubuntu 18.04 and Skype installed trough snap was working very fine, but suddenly Skype stopped connecting and just return the error "HTTP Error 400. The request is badly formed."

I tried to logout to login again to see if it would help, but now I can't even login again. When I choose my username it returns me the same error 400 before even asking for a password.

I searched and founded that this error 400 is related to some broken cookies, so I tried to delete the file "Cookies" and some other stuff on skype config folder in my home directory (I did a backup before) but It doesn't work.

Then I tried another possible solution. I uninstalled the snap Skype and downloaded the .deb from the official Skype website and tried to install it using dpkg. I needed to solve some dependencies with apt, then installed the deb package, but the problem still persists! I don't know what is happening, but apparently the .deb version imported some configs from the previous snap version.

I haven't made any considerable change on Ubuntu or Skype (like upgrading) before that error. I have no idea why it is occurring. I would be very glad if someone could help me to get rid off this annoying problem!

  • just a workaround, you can try the flatpak version of skype. Here is how to install flatpak, and the flatpak version of skype – dsSTORM Jan 5 '19 at 16:23
0

SOLVED! Thanks for answering dsSTORM, but i dealed with it with a little bit different solution.

What I have done was to unistall completely the Skype using: $ sudo apt-get --purge remove skypeforlinux $ sudo apt autoremove $ sudo apt-get clean

Then, I searched at my root directory for the term "skype" and deleted all config files in home folder and others like /usr, /var and maybe others that I just can't remember (was a bunch of them). For some files I needed root.

Then I reinstalled Skype using:

$ sudo dpkg -i skypeforlinux-64.deb (downloaded from the official skype website)

Then I had to solve some dependencies using apt and now it's working fine!

I don't have a clue of what have caused that problem, and maybe that's not the best and most elegant solution, but at least it's working fine now. Hope it doesn't happen again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.