0

I just build a desktop with Gigabyte Z390 Designare. I have set it up with a dual boot Windows 10 and Ubuntu 18.04.

I am able to connect to the Wifi in Windows. There is onboard wi-fi adapter with Intel CNVi 9560.

However, Ubuntu doesn't detect the network adapter.

I ran the code and I don't see the wireless adapter. Would appreciate some help so that I can start using Linux

00:00.0 Host bridge: Intel Corporation Device 3e30 (rev 0a)
00:02.0 VGA compatible controller: Intel Corporation Device 3e98
00:12.0 Signal processing controller: Intel Corporation Device a379 (rev 10)
00:14.0 USB controller: Intel Corporation Device a36d (rev 10)
00:14.2 RAM memory: Intel Corporation Device a36f (rev 10)
00:14.3 Network controller: Intel Corporation Device a370 (rev 10)
00:16.0 Communication controller: Intel Corporation Device a360 (rev 10)
00:17.0 SATA controller: Intel Corporation Device a352 (rev 10)
00:1b.0 PCI bridge: Intel Corporation Device a340 (rev f0)
00:1c.0 PCI bridge: Intel Corporation Device a338 (rev f0)
00:1c.1 PCI bridge: Intel Corporation Device a339 (rev f0)
00:1c.4 PCI bridge: Intel Corporation Device a33c (rev f0)
00:1d.0 PCI bridge: Intel Corporation Device a330 (rev f0)
00:1f.0 ISA bridge: Intel Corporation Device a305 (rev 10)
00:1f.3 Audio device: Intel Corporation Device a348 (rev 10)
00:1f.4 SMBus: Intel Corporation Device a323 (rev 10)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Device a324 (rev 10)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (7) I219-V (rev 10)
01:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd Device a808
03:00.0 Ethernet controller: Intel Corporation I211 Gigabit Network Connection (rev 03)

I ran dmesg | grep iwl

[    6.130762] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
[    6.141173] iwlwifi 0000:00:14.3: loaded firmware version 34.0.0 op_mode iwlmvm
[    6.183949] iwlwifi 0000:00:14.3: Detected Intel(R) Dual Band Wireless AC 9560, REV=0x318
[    6.190560] kernel BUG at /build/linux-vxxS7y/linux-4.15.0/drivers/net/wireless/intel/iwlwifi/pcie/rx.c:425!
[    6.190565] Modules linked in: kvm(+) snd_hda_core snd_hwdep iwlmvm(+) irqbypass snd_pcm crct10dif_pclmul crc32_pclmul ghash_clmulni_intel mac80211 pcbc snd_seq_midi snd_seq_midi_event aesni_intel snd_rawmidi btusb aes_x86_64 crypto_simd iwlwifi glue_helper cryptd input_leds btrtl snd_seq btbcm intel_cstate btintel joydev snd_seq_device intel_rapl_perf bluetooth snd_timer snd ecdh_generic wmi_bmof intel_wmi_thunderbolt soundcore cfg80211 mei_me mei shpchp intel_pch_thermal acpi_pad mac_hid sch_fq_codel parport_pc ppdev lp parport ip_tables x_tables autofs4 hid_generic usbhid hid i915 mxm_wmi drm_kms_helper igb syscopyarea sysfillrect sysimgblt dca fb_sys_fops e1000e i2c_algo_bit nvme drm ptp ahci i2c_i801 nvme_core pps_core libahci wmi video
[    6.190590] RIP: 0010:iwl_pcie_rxq_alloc_rbs+0x1d0/0x1f0 [iwlwifi]
[    6.190604]  _iwl_pcie_rx_init+0x252/0x710 [iwlwifi]
[    6.190607]  iwl_pcie_rx_init+0x2d/0x3c0 [iwlwifi]
[    6.190613]  ? iwl_mvm_nic_config+0xeb/0x120 [iwlmvm]
[    6.190617]  iwl_trans_pcie_start_fw+0x2a1/0x6c0 [iwlwifi]
[    6.190621]  iwl_mvm_load_ucode_wait_alive+0xec/0x2b0 [iwlmvm]
[    6.190626]  iwl_run_init_mvm_ucode+0x8e/0x330 [iwlmvm]
[    6.190629]  ? iwl_run_init_mvm_ucode+0x8e/0x330 [iwlmvm]
[    6.190632]  ? iwl_wait_init_complete+0x20/0x20 [iwlmvm]
[    6.190636]  iwl_op_mode_mvm_start+0x649/0x920 [iwlmvm]
[    6.190639]  ? iwl_op_mode_mvm_start+0x649/0x920 [iwlmvm]
[    6.190642]  _iwl_op_mode_start.isra.10+0x4c/0xa0 [iwlwifi]
[    6.190644]  iwl_opmode_register+0x75/0xe0 [iwlwifi]
[    6.190648]  iwl_mvm_init+0x38/0x1000 [iwlmvm]
[    6.190692] RIP: iwl_pcie_rxq_alloc_rbs+0x1d0/0x1f0 [iwlwifi] RSP: ffffb01b4400f8a8
3
  • Should also write the command you ran.
    – Vijay
    Jan 5, 2019 at 14:05
  • probably your ubuntu has no driver for the wifi. I guess you should get linux driver from the laptop/wifi manufacturer
    – Greg
    Jan 5, 2019 at 14:27
  • I ran dmesg | grep iwl and got the following
    – Wee Kim
    Jan 5, 2019 at 15:38

1 Answer 1

1

This is your wireless device:

Network controller: Intel Corporation Device a370 (rev 10)

We note this error in the message log:

kernel BUG at /build/linux-vxxS7y/linux-4.15.0/drivers/net/wireless/intel/iwlwifi/pcie/rx.c:425!

Congratulations! You are the subject of an official bug! https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1809483

The similar bug report at Red Hat here suggests that the bug is fixed in kernel versions 4.17 et seq: https://bugzilla.redhat.com/show_bug.cgi?id=1574679

I suggest that you download and try the live session for Ubuntu 18.10 which uses kernel version 4.18 to see if the bug is present. If not and, as I suspect, the wireless is working as expected, install it.

1
  • Tried it on 18.10 and it worked. Will proceed to upgrade to it
    – Wee Kim
    Jan 6, 2019 at 0:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .