0

I'm migrating my system from 14.04. to 18.04. and was happy to see that there was a letodms package in the repository that was smoothly integrated by apt adding all necessities like the apache, php7, mysql package etc.

However, configuring letodms was not as easy as I remembered it from 2 years ago, and there seems to be little to no documentation on the net nowadays.

When pointing a browser to http://localhost/letodms (/var/www/html/letodms) there is no installation routine in php as there used to be, simply an empty page is displayed.

The apache reports an error in it's logs, saying that mysql_connect is an undefined function.

Evidently mysql_connect is depreciated since php5 and I have tried several workarounds I found on the net, but none worked.

I expected, since the package is in the repository, that someone had it working, and am wondering if I "forgot to put gas i the tank" in the sense of not seeing a mistake I am making that is so basic that I don't think of it.

Has anyone else encountered this problem?

  • 1
    you check localhost/phpmyadmin is working? – KGR Jan 5 at 11:08
  • How did you installed letodms? It is packaged... – N0rbert Jan 5 at 11:16
  • Yes. It's working fine. – Coney Jan 5 at 11:27
  • I installed it per apt [sudo apt install letodms] and it went in smoothly. – Coney Jan 5 at 11:29
  • This error appears in the apache's error.log repetitively: Part 1 [php7:error] [pid 30885] [client 127.0.0.1:36640] PHP Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /usr/share/php/adodb/drivers/adodb-mysql.inc.php:461\nStack trace:\n#0 /usr/share/php/adodb/ – Coney Jan 5 at 11:34

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.