1

I tried to upgrade from Ubuntu 16.04 to Ubuntu 18.04 this morning. Everything went alright, except when the system finished upgrading and tried to reboot it could not enter the desktop environment and got stuck at a purple screen with 'ubuntu' and five dots below it. It lasted for about 5 hours when I realized that something probably had gone wrong.

0

Ubuntu 18.04 was not booting to the desktop environment because there was a problem with the Nvidia graphics driver. The computer has two GPUs, an integrated Intel GPU and a discrete Nvidia GTX 1050 graphics card. After changing the custom GPU to Intel in the BIOS/UEFI setup utility, it just worked.


Install proprietary Nvidia GTX 1050 graphics driver

Uninstall the existing proprietary Nvidia graphics driver and reboot before trying to automatically install the proprietary Nvidia graphics driver in Ubuntu 18.04. Don't uninstall the open source Nouveau graphics driver. The proprietary Nvidia graphics driver for the Nvidia GTX 1050 GPU can be installed in Ubuntu 18.04 from the terminal or console with the following commands:

sudo ubuntu-drivers autoinstall  
sudo reboot    

When installing a proprietary graphics driver, it is not necessary to uninstall the built-in Nouveau open source graphics driver. The two graphics drivers can be installed alongside each other allowing the open source graphics driver to be used as a fallback alternative in case there is a problem using the proprietary graphics driver.

The ubuntu-drivers autoinstall command installs drivers that are appropriate for automatic installation including their dependencies, and the Nvidia driver will also be updated automatically when an update is available.

  • Did you mean I need to recover the old kernel using GRUB. I'll have a try. – bob wong Jan 5 at 10:23
  • Recovering an old kernel with grub will only make matters worse because the kernel is OK, otherwise it wouldn't have shown the purple screen with the 5 dots. After you get into recovery mode the best option to try first is the failsafeX option which may be able to get into a low resolution GUI desktop environment. Then you can fix the rest of it from the terminal. – karel Jan 5 at 10:28
  • Got it. Thanks a lot. – bob wong Jan 5 at 10:30
  • Well, it did not give an error message. But it just did not work. I tried the recovery mode with clean, dpkg and grub. After it, I tried both resume from recovery mode and failsafeX. It just gave me some messages about some information of my shadowsocks(not an error) and stuck there. – bob wong Jan 5 at 11:10
  • Instead of entering the virtual console it would be easier for you to select the root option from recovery mode. After selecting root the command prompt changes to # and you can run commands that require root permissions without prefacing them with sudo. For example, instead of sudo apt install lightdm type apt install lightdm – karel Jan 5 at 11:18
0

You may have a problem with an older computer, with an older GPU. Try this...

  • boot to recovery mode
  • choose root access

type:

sudo mount -o remount,rw /      # to remount the disk r/w

sudo pico /etc/gdm3/custom.conf # edit this file

change:

#WaylandEnable=false

to:

WaylandEnable=false

Then reboot.

0

The old machine I was using did this same thing, I realised it was because it's only 32 bit capable and 18.x is 64 bit

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.