0

TL;DR This python-based key remapping software ceased working after upgrade to 18.04 from 16.04 and I would like it or the supposed Python3 compliant version to work. Help!

Detailed description: I use a Razer Tartarus and sometimes a Belkin n52 to play games on Ubuntu, but after an upgrade from 16.04 to 18.04, the software version 0.6.0 runs but none of the key bindings except for changing the LED colors have any affect. Python 2.7 and Python3 are both installed and doing 'Python' in a terminal results in the 2.7 version.

I tried numerous (but not all) keys to bind in the .map file the program uses for binding keys to my gameboards but I think Python changed key identifiers in some way, making my current .map profiles not work right. The program runs and the profile loads but as noted above, not right.

To test, I installed 18.04 fresh on another machine and it exhibits the same issue in the same manner. I then booted into a live USB with 16.04 and verified it worked fine. I've spend some time making install scripts and writing documentation for this software, though I am not the author or maintainer, and I could not code my way out of a wet paper bag. I also tried running it with 'python2' before the python-remap.py and that did not seem to change the results.

You can get the last release of v0.6.0 here: https://github.com/byrongibson/Pystromo

Version 0.6.1, supposedly updated to use Python3, can be found here: https://github.com/booms8/Pystromo

However, v0.6.1 has a number of 'failed to load' messages when trying to import a couple different Python modules, and I would like to get that version working to future-proof myself for when Python2 goes out of support (I heard).

I realize this cry for help crosses into a couple possible websites' territory, namely: 1) 'contact the developer', but they are not maintaining the code anymore, and 2) Python.org might be a better place to figure out Python stuff but more eyes here was my first thought.

I can use Keyboardingmaster for both gameboards and it works on both 16.04 and 18.04, for the Razer Tartarus/Chroma and Orbweaver/Chroma (so it says), but the Pystromo program is less than a megabyte in size and works(ed?) great, plus the work I had put into making install and launcher scripts for it.

Please help me get this working again!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.