4

I want to use gdm3 but unfortunately, it does not work. After booting it just completely hangs.

enter image description here
boot process stopped after Started GNOME Display Manager

It just does not do anything. Installing lightdm and activating it via sudo dpkg-reconfigure lightdm does work but then again that's not what I want.

I tried several things already:

  • Reinstalling NVIDIA drivers
  • Changing my run level to multi-user.target
  • Using update-rc.d -f gdm3 remove && update-rc.d gdm3 defaults to reconfigure gdm3
  • Installing the packages that I need sudo apt-get install ubuntu-gnome-desktop gnome-shell gnome
  • Reinstalling gdm3

Does anyone know how I can get gdm3 to work?

  • 2
    How old is this computer? Exactly WHERE does it hang? Do you see the splash screen? At the GRUB menu, edit the kernel line that says "quiet splash" and add "nomodeset" and see if that allows it to boot. If it does, I'll give you a permanent fix. Report back to @heynnema – heynnema Jan 5 '19 at 2:49
  • @heynnema When I'm booting I'm seeing the GNU GRUB version 2.02 screen. I went to advanced options -> Ubuntu with Linux 4.18.0-10-generic and added nomodeset so it's now linux /boot/vmlinuz-4.18.0-10-generic root=UUID=62de2584-320c-49c3-85f4-057c6c967281 ro quiet splash nomodeset $vt_handoff. I pressed F10. Got to the Splash Screen showing Ubuntu 18.10 and from the same log messages appeared as above and this is the point where it hangs. This computer is quite old. ~2012 NVIDIA 660TI with Intel i7 3770k – Niklas Jan 5 '19 at 12:33
  • Please see my answer for something quick to try. If it doesn't work, we may try to uninstall the Nvidia drivers, and see what happens. Report back to @heynnema – heynnema Jan 5 '19 at 23:16
  • How did you "Changing my run level to multi-user.target"? – heynnema Jan 7 '19 at 22:58
  • sudo systemctl isolate multi-user.target && sudo systemctl enable multi-user.target && sudo systemctl set-default multi-user.target – Niklas Jan 9 '19 at 18:27
3

Not sure if this is going to fix your problem, but it's quick, so it's worth a try...

You may have a problem with an older computer, with an older GPU. Try this...

  • boot to recovery mode
  • choose root access

type:

sudo mount -o remount,rw /      # to remount the disk r/w

sudo pico /etc/gdm3/custom.conf # edit this file

change:

#WaylandEnable=false

to:

WaylandEnable=false

Then reboot.

| improve this answer | |
  • Went into Grub. Selected Ubuntu with Linux 4.18.0-10-generic (recovery mode). From there I got to the point where I'm seeing Started Update UTMP about System Runlevel Changes and from there I'm stuck again. It does not go further. – Niklas Jan 7 '19 at 22:40
  • @Niklas Is this what's happening AFTER the mod in my answer? Do you have both Intel and Nvidia GPU's on your system? If so, go to the BIOS and temporarily select the Intel GPU and see if you get farther. If you do, the Nvidia driver is suspect. What version is it? – heynnema Jan 7 '19 at 22:57
  • 1
    Sorry for the long silence. Finally solved this by disabling my NVIDIA graphics card and using the normal Intel one. Now everything works. Thanks for all of your help. – Niklas Apr 29 '19 at 21:08
  • @Niklas how did you disable the NVIDIA graphics card? I have a similar problem and would like to see if that helps for me. – Elias May 3 '19 at 14:13
  • I went into the BIOS and switched the Graphic card selection from Auto to the Intel One. You can look up how to change that on the manufacturer website of your mainboard. – Niklas May 4 '19 at 18:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.