2

Audio was working previously. In settings>sound, it shows "Dummy output".

No card is shown.

$ pacmd list-cards
0 card(s) available.

Although device is shown

$ lspci -nnk | grep -A2 Audio
00:1f.3 Audio device [0403]: Intel Corporation Sunrise Point-LP HD Audio [8086:9d71] (rev 21)
    Subsystem: Hewlett-Packard Company Sunrise Point-LP HD Audio [103c:832b]
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel, snd_soc_skl

No audio with headphone/earphone as well. It might be relevant that the problem occured when I was trying to fix bluetooth audio problem using this link -

A2DP on PulseAudio - terrible choppy/skipping audio

Although I edited /etc/modprobe.d/alsa-base.conf by appending 'options snd-hda-intel model=generic' at the end, I removed it afterwards but still the problem persisted. I don't know exactly what trigerred the problem.

Also, There is no option for audio devices in BIOS (My laptop model is HP 15bs180tx) as suggested by "Joel Kleier's" answer to -

"Dummy Output" No sound in Ubuntu 16.04

0

I figured it out. Turns out that the answer asking to enable audio from BIOS would've worked but the option is not present in my laptop. Also, the audio stopped working in windows as well (dual boot), so I reset to setup defaults (not the restore factory settings) and audio started working.

Also, for skipping audio problem, it occurs whenever WiFi and bluetooth both are working at same time, seems some kind of interference in both the signals. So, either switch off WiFi while using bluetooth audio or first start bluetooth and connect to the device and then open WiFi to connect.

| improve this answer | |
  • You would've had a good answer if you had explained how to do some of the things you mentioned. For ex, what is "I reset to setup defaults (not restore factory settings)" supposed to mean? Your wording suggests you were dealing with a cellphone, not a laptop, for example... – code_dredd May 12 at 17:09
  • These are the options present in my BIOS menu, My device is a laptop, which is mentioned in the question itself. – BEWARB May 12 at 19:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.