2

I have dynamic workspaces enabled in Tweaks because I occasionally like to switch between windows quickly without having to use the "switch application" shortcut. I like to use a transparent terminal with just my desktop wallpaper in the background, but if I'm using my browser or any window with text displayed it doesn't make sense to open up a transparent terminal window on top of that. So I separate windows into dynamically created workspaces. The only problem is, they aren't automatically removed when they become empty and I don't see any shortcuts/settings in Tweaks to manually remove the empty workspaces. In fact, there's always two workspaces open by default for some reason, and if I have open additional workspaces I can only bring it back down to two if I close every app I have open. Any ideas?

For reference:

Ubuntu 18.04.1 LTS

GNOME Shell 3.28.3

GTK+ 3.22.30

5
  • Are you using any GNOME extension(s)? If yes, what happens if you disable them all?
    – pomsky
    Jan 4, 2019 at 6:36
  • The only extensions I have enabled are Ubuntu appindicators, Ubuntu dock, and User themes. When I disable all of them, the only thing that changes is the workspace icon that appears when I press the the shortcut for it. Jan 4, 2019 at 6:52
  • 1
    You always will have at least two work spaces, one empty and ready to use. You mean you keep having an empty workspaces in between filled workspaces when you emptied it? It normally should close by default. It is normal that a last empty one remains, ready for use.
    – vanadium
    Jan 4, 2019 at 7:43
  • @vanadium I was not aware that an empty workspace was always kept on deck. In that case, my workspaces are behaving normally. Can you repost your comment as an answer so I can mark this question as solved? Jan 6, 2019 at 22:55
  • That is probably implemented this way for "discoverability", so users at any time see in the overview that there is more than the current work space. I turned it into an answer indeed.
    – vanadium
    Jan 7, 2019 at 8:15

1 Answer 1

3

In Gnome Shell, you always will have at least two work spaces, one and the end, empty and ready to use. Empty workspaces in between used workspaces will automatically be closed when they are not anymore in use. However, the last empty one remains, ready for use. This is normal behaviour in Gnome Shell.

5
  • Using dynamic workspaces. You can use gnome-tweaks to change it to a static 1 so accidental window moving will be a thing of the past. Sep 26, 2019 at 10:18
  • The OP is not looking to disable workspaces, but instead is actively using them. The question is about hiding the extra empty workspace that Gnome Shell always shows.
    – vanadium
    Sep 27, 2019 at 6:54
  • Then use 2 instead of 1, or whatever number OP actually uses. Sep 27, 2019 at 8:51
  • I did not ask the question: it is what it is, a request, when using dynamic workspaces, to see only the ones currently in use. Not possible to achieve that in Gnome Shell. Accordingly, that is what I answered.
    – vanadium
    Sep 27, 2019 at 15:54
  • I have 3 extra, empty workspaces now. When I alt-tab on them nothing shows up, so there's nothing there.
    – Ctrl-C
    Oct 22, 2021 at 9:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.