I put an audio cd in the drive on my new 18.04 installation, started Rhythmbox, selected all and clicked "Extract". It extracted the first track and stopped. Whenever I try to rip more tracks, I get the message "Could not open resource for writing."

I tried to change the format to MP3, but then I'm told to install additional software, but not which software.

I tried to install Sound Juicer, and I should just have ripped my cd in Ogg Vorbis format, but I had to try and change the format to MP3, and now whenever I start Sound Juicer, I get a "Cancel or switch profile" dialog, but whatever I choose, Sound Juicer closes. I tried to uninstall it and install it again, but now that dialog comes up regardsless, and the program closes whatever I choose.

  • It sounds like you have configured rhythmbox poorly, or you do not have ownership of ~/Music. Have you been using sudo? – waltinator Jan 3 '19 at 23:37
  • I have ownership of ~/Music. If I type $ sudo rhythmbox & it stops right away. – OZ1SEJ Jan 4 '19 at 6:22
  • I'm not a Ubuntu user, but I've been using CDex in Win7 system for quite a while to rip my CDs to 256 joint stereo to play back on my phone. Works great. Have to clean up the song names sometimes, folks who have submitted the databases for the albums do funny things sometimes. cdex.mu en.wikipedia.org/wiki/CDex I'd have to check which version I have (and I have had it quite a while), I haven't seen the adware mentioned in Wikipedia article - or else Norton Antivirus or whatever blocking Comcast has in place is taking care of it. – CrossRoads May 7 '19 at 13:48

fre:ac works on my Ubuntu 18.04 system. I did not succeed with rythmbox, Amarok, asunder, audacious and sound juicer for getting mp3 files from my audio CD.


I encountered the same error (in Rhythmbox 3.4.2, German, it reads "Die Ressource konnte nicht zum Schreiben geöffnet werden") and noticed that it disappeared immediately after I had enabled the group write access to the music folder.

chmod g+w ~/Musik

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.