I'm trying to get Ubuntu 18.04.1 up and running on a Thinkpad E485. The computer has two drives installed. An M.2 SSD (boot) and a SATA HDD (data). I've added the kernel parameter ivrs_ioapic[32]=00:14.0 to get it to boot (thanks to Evil Azrael), and most things seem to work now.

An issue I have is whenever I restart the computer, it comes back up with the BIOS boot screen Boot Screen. FYI, the Toshiba is the HDD data disk. No matter what you select on the boot screen, it immediately pops back up. As a result, I have to hold the switch and power off.

I tried a lot of things before I realized this does not happen if I select shutdown in Ubuntu vs. restart. This is my workaround, but if others have had/resolved such an issue, I'd be interested in knowing how. Some things I learned/tried along the way:

  1. Currently booting UEFI with Smartboot enabled (but tried disabling and same thing)
  2. Tried legacy/MBR and similar issue.
  3. W10 alone has no such issue.
  4. W10 dual booted with Ubuntu also has no such issue, but again Ubuntu does.
  5. Tried Ubuntu installed and booting from the HDD disk and same issue.

Again, what I have now works but it's annoying - as a noob I restart the computer a lot :-) Any suggestions welcome.

2 Answers 2


you have to add these parameters to the kernel line in grub

ivrs_ioapic[32]=00:14.0 ivrs_ioapic[33]=00:00.1 spec_store_bypass_disable=seccomp

on my system it's in /etc/default/grub and the whole line looks like this

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash ivrs_ioapic[32]=00:14.0 ivrs_ioapic[33]=00:00.1 spec_store_bypass_disable=seccomp idle=nomwait"

I found this information here - the author eventually sold his E485, which I am on the verge of doing as well.

  • I was just able to upgrade to kernel 4.20.7 using UKUU by adding an additional parameter - iommu=soft Feb 7, 2019 at 10:03
  • Thanks! After upgrading the kernel from 4.15 to 4.20 this did the trick. Feb 12, 2019 at 19:58
  • With my current kernel, 5.1.16-050116-generic, I was able to remove the parameter amd_iommu=on, leaving just iommu=soft. Jul 25, 2019 at 18:32

For Ubuntu 19.04 (Linux Kernel 5.0), the following parameters made the ThinkPad boot:

ivrs_ioapic[32]=00:14.0 ivrs_ioapic[33]=00:00.1

and black screen on resume from suspend/sleep with closed lid could be solved with


These parmeters are applied in /etc/default/grub in the GRUB_CMDLINE_LINUX_DEFAULT variable and set via

sudo update-grub

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.