I have a Toshiba Satellite A105. It worked OK with Windows on it, but it works amazingly with Ubuntu. I really like Ubuntu so far.

With one exception: The wireless is extremely slow. Ridiculously so, you have to wait 10 minutes for one webpage to load. If I connect it with an ethernet cable it works just fine, or if I use a Windows computer. I've found many 'solutions' for this problem, but none of them have worked.

I've got an Intel PRO/Wireless 3945abg wireless card. Here's what I've tried so far:

  1. Disabling IPv6 (like this place suggests). Nothing changed, as far as I could tell.
  2. Using WICD instead of of Network Manager (as outlined here: www.dreamlogic.net/archives/fixing-slow-wifi-in-ubuntu-11-10. It worked briefly, and then it stopped working entirely.
  3. Using NDISWrapper to install a Dell Driver, as outlined here: www.overclock.net/t/368589/solved-slow-wireless-speeds-in-ubuntu-but-not-vista#post_4334413.
  4. I've tried all of this stuff. Unsuccessfully.

I'm pretty new to Linux, so if you could instruct my foolishness I would be much obliged. Thanks a lot!

Oh, and I'm running Oneiric Ocelot (11.10), by the way.


As it turns out, my wireless card was dying. I purchased a Panda Wireless adapter (on Amazon), plugged it in, and it now works perfectly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.