16

I had a powercut last night and ever since then when I try to access the Ask Ubuntu Chat, I see the following error in Firebug.

Component returned failure code: 0x8052000b (NS_ERROR_FILE_CORRUPTED) [nsIDOMStorage.getItem]

I assume I'm getting this because the storage that Firefox uses for HTML5 local storage (which SE Chat uses to cache the session) has been corrupted by the dirty reboot.

No amount of force-refreshing seems to fix this, so what do I do now?

I have already tried:

  • Nuking my "Offline Storage" from the Preferences screen.
  • rmming localstore.rdf
19

Firefox stores its HTML5 data in a file called webappsstore.sqlite. That's sitting in your profile directory which lurks somewhere in ~/.mozilla/firefox/....default/ (depending on what your profile is called).

Move that out the way and restart Firefox and everything will come back to life.

| improve this answer | |
  • 1
    This can also happen with pentadactyl, in which case delete the cache.zip file (in %USERPROFILE%\AppData\Roaming\Mozilla\Firefox\Profiles\<your profile>.default\dactyl) – 79E09796 May 16 '13 at 14:09
  • This fixed Slack and Trello for me. – Konrad Höffner Nov 1 '16 at 13:23
  • This is a potentially destructive action (you will lose local storage data). A possibly better solution is outlined in askubuntu.com/a/1181926/556982 – millerdev Oct 28 '19 at 14:24
  • Is there a way to recover data from the corrupted sqlite file? opening it in a regular sqlite browser doesn't seem to work – Peeyush Kushwaha Mar 12 at 15:15
2

What fixed it for me when I had that error with BitBucket (again) was the clicking the button Clear Cookies and Site Data.... You can arrive at that button by clicking at the symbols right before the web address (an i withing a circle, or a green lock, or a crossed out lock, or something similar). Then you get a popup dialog at the end of which you can find the aforementioned button: An image of the "Clear Cookies and Site Data..." button.

| improve this answer | |
  • This did not work for me. – millerdev Oct 18 '19 at 16:14
  • Okay. If I recall correctly, the timing might have been important as well. It might have mattered whether I clicked that button at the login screen, during login process, or after logging in - it displayed a different cookies at different points (parent company vs specific product). To be certain, one might want to delete cookies at each of those points. --- But it is also completely possible you and I had different problems with different solutions, while seeing the same error message. – Carolus Oct 22 '19 at 9:35
  • Deleting the sqlites files did not works for me. I needed to additionally clear the site data. Now it seem to be working. – Yeasin Ar Rahman Oct 23 '19 at 7:59
1

I was able to resolve this issue using a procedure similar to the one outlined in https://superuser.com/a/1329161 (replace places.sqlite with webappsstore.sqlite in those instructions). The advantage is that this preserves (uncorrupted) content of webappsstore.sqlite, which contains local storage data.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.