0

I'm dual booting windows and ubuntu. Apparently I encrypted my home folder when I installed ubuntu, though I don't remember choosing that. I tried to access files on the ubuntu partition while running windows, and now ecryptfs has made it so that I cant access my home folder.

There is a README file, when I click on it i get "This link cannot be used because its target “\usr\share\ecryptfs-utils\ecryptfs-mount-private.txt” doesn't exist."

There is a file called Access-Your-Private-Data.desktop, when I click on it I get "This link cannot be used because its target “\usr\share\ecryptfs-utils\ecryptfs-mount-private.desktop” doesn't exist."

If I navigate to \usr\share\ecryptfs-utils\ then I find ecryptfs-mount-private.desktop is there. When I click on it a window opens then closes very quickly and a question mark box appears on the launcher bar, then after a minute it goes away without seeming to do anything.

Reading other posts online, I tried sudo ecrypt-recover-private and I get here

chris@chris-M11xR3:~$ sudo ecryptfs-recover-private
INFO: Searching for encrypted private directories (this might take a while)...
INFO: Found [/home/.ecryptfs/chris/.Private].
Try to recover this directory? [Y/n]: y
INFO: Found your wrapped-passphrase
Do you know your LOGIN passphrase? [Y/n] nixie09
INFO: To recover this directory, you MUST have your original MOUNT passphrase.
INFO: When you first setup your encrypted private directory, you were told to record
INFO: your MOUNT passphrase.
INFO: It should be 32 characters long, consisting of [0-9] and [a-f].

Enter your MOUNT passphrase: 

The problem now is that I don't know the passphrase. I've seen things that suggest its possible to recover it using ecrypt-unwrap-passphrase, but I get this

chris@chris-M11xR3:~$ sudo ecryptfs-unwrap-passphrase
[sudo] password for chris: 
stat: No such file or directory
Usage:

ecryptfs-unwrap-passphrase [file]
or
printf "%s" "wrapping passphrase" | ecryptfs-unwrap-passphrase [file] -

and again I'm stuck.

Please help, I desperately need some of the files I was working on earlier today.

1

I think you gave up too soon with ecryptfs-recover-private, it looks like when it came to the line asking you

Do you know your LOGIN passphrase? [Y/n]

instead of pressing enter, or y then enter, you typed in something beginning with an n, which the script took to mean "no" and then asked you for the mount passphrase instead.

So, try it again, but with Y when it asks for the login passphrase.


And, if you have to run ecryptfs-unwrap-passphrase again, try looking for the wrapped-passphrase file somewhere in/around /home/.ecryptfs/chris/.Private, and then tell the unwrap script where it is specifically.

  • Thank you. Between the stress, sleep deprivation, and approaching panic attack, I was putting in my facebook password for some reason. Now that I can access the files, is there an easy way to restore the home folder to the way it was without backing everything up and then copying it over back into the home folder? Thank you so much. – chris Jan 3 at 12:51
  • No problem. If this solved the problem, don't forget to upvote / select as correct :) I'm not sure how the home was before, but you could make a new (unencrypted) user and copy your old home files to the new user's home (without the .ecryptfs & .Private links), perhaps with the same name & ID if you delete the old user first, or after then change the new user... – Xen2050 Jan 4 at 8:19

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.