1

EDIT: I tried buying a USB Audio Card (USB Audio Adapter); it ouputs audio fine, but still no luck getting audio input. Interestingly, though, when I plug in my headset into the microphone jack I do get some bars in Sound > Input indicating it is receiving something. Additionally, in AlsaMixer if I switch sound cards to USB Audio Device and then go to 'capture device', I do see a Mic with a EQ bar above it that I can adjust, with CAPTURE in red text just below the EQ bar

Fresh install of Ubuntu 18.04. No audio input from onboard mic or headphone/mic combo (these both work fine when I boot same machine, Acer Swift 3 SF314-54, via Windows 10), alsamixer showing "sound device has no capture controls".

I don't know if it's related, but I installed "Pulse Audio Shortcuts" extension and when I try to turn it on in the extensions section of the GNOME Tweaks program I see a yellow warning triangle with "Error loading extension" next to it. I don't appear to have gstreamer-properties command, either, even though I believe PulseAudio comes with 18.04?

Anyways, would be very grateful for approaches to solve this, thanks!

Here's my input and output settings:

~$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC256 Analog [ALC256 Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 2: ALC256 Alt Analog [ALC256 Alt Analog]
Subdevices: 2/2
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1

~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC256 Analog [ALC256 Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
Subdevices: 1/1
Subdevice #0: subdevice #0

ALSA settings screenshot

ALSA "no capture device setting" screenshot

Here's some related threads [1] [2] [3] [4]; I've tried basically all of the solutions suggested therein, except—as there were a number of different suggestions for how to modify /etc/modprobe.d/alsa-base.conf—I've only tried a couple of these but not all.

0

Solved it with the USB Audio Adapter (examples) plus using a headset with a 3.5mm splitter.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.